summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2002-12-08 14:50:10 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2002-12-08 14:50:10 +0000
commit708cf898e85bb1742870f6b3cabcc74b28f01c5f (patch)
tree022549fcd528cd742ef2fc6569ebd94a0030e97f /Makefile.am
parent2a19514098f24c47f8642e7f0b4b762e5dc9d05d (diff)
downloadgst-plugins-bad-708cf898e85bb1742870f6b3cabcc74b28f01c5f.tar.gz
gst-plugins-bad-708cf898e85bb1742870f6b3cabcc74b28f01c5f.tar.bz2
gst-plugins-bad-708cf898e85bb1742870f6b3cabcc74b28f01c5f.zip
parallel install fixes
Original commit message from CVS: parallel install fixes
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 696b60d5..cd4a884a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,11 +16,20 @@ else
EXAMPLES_DIR=
endif
+gstreamer-libs-@GST_MAJORMINOR@.pc: gstreamer-libs.pc
+ cp gstreamer-libs.pc gstreamer-libs-@GST_MAJORMINOR@.pc
+gstreamer-play-@GST_MAJORMINOR@.pc: gstreamer-play.pc
+ cp gstreamer-play.pc gstreamer-play-@GST_MAJORMINOR@.pc
+gst_element_check-@GST_MAJORMINOR@.m4: gst-element-check.m4
+ cp gst-element-check.m4 gst-element-check-@GST_MAJORMINOR@.m4
+
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = gstreamer-libs.pc gstreamer-play.pc
+pkgconfig_DATA = \
+ gstreamer-libs-@GST_MAJORMINOR@.pc \
+ gstreamer-play-@GST_MAJORMINOR@.pc
aclocaldir = $(datadir)/aclocal
-aclocal_DATA = gst-element-check.m4
+aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
SUBDIRS=gst-libs gst sys $(EXT_DIR) $(EXAMPLES_DIR) tools $(GCONF_DIR) testsuite