summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2004-06-24 01:43:55 +0000
committerBenjamin Otte <otte@gnome.org>2004-06-24 01:43:55 +0000
commit838bc540841852e032694814668aa436849e6f9d (patch)
treeb17c61d4705d6333aa8fb364f41962e0793f4154 /Makefile.am
parentbe7c1e4d8024f196265535ab18c3d71e8f9571ad (diff)
downloadgst-plugins-bad-838bc540841852e032694814668aa436849e6f9d.tar.gz
gst-plugins-bad-838bc540841852e032694814668aa436849e6f9d.tar.bz2
gst-plugins-bad-838bc540841852e032694814668aa436849e6f9d.zip
don't include -enumtypes.[ch] or -marshal.[ch] files in the disted tarball.
Original commit message from CVS: * gst-libs/gst/colorbalance/Makefile.am: * gst-libs/gst/mixer/Makefile.am: * gst-libs/gst/play/Makefile.am: * gst-libs/gst/tuner/Makefile.am: * gst/tcp/Makefile.am: * sys/dxr3/Makefile.am: don't include -enumtypes.[ch] or -marshal.[ch] files in the disted tarball. Also add all *.list files that were missing. * Makefile.am: add a distcheck hook to ensure the above doesn't happen again.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 258a79c8..d773bc68 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,5 +44,13 @@ EXTRA_DIST=gst-plugins.spec depcomp \
DISTCLEANFILES=_stdint.h
+# check that no marshal or enumtypes files are included
+# this in turn ensures that distcheck fails for missing .list files which is currently
+# shadowed when the corresponding .c and .h files are included.
+distcheck-hook:
+ test "x" = "x`find $(distdir) -name \*-enumtypes.[ch]`" && \
+ test "x" = "x`find $(distdir) -name \*-marshal.[ch]`" || \
+ ( $(ECHO) "*** Still leftover enumtypes or marshal files in the tarball. Please make sure those are not disted." && false )
+
include $(top_srcdir)/common/release.mak
include $(top_srcdir)/common/po.mak