summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2003-11-07 00:53:32 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2003-11-07 00:53:32 +0000
commit2a6ab3709a3997b0b023445d6e9beaa76d6f915d (patch)
tree4014e8e7744a18e5252da86330b5fbe789e67dcf /configure.ac
parentbfeed7aeacee5fdfd50a19b42d2271c0a1d297ed (diff)
downloadgst-plugins-bad-2a6ab3709a3997b0b023445d6e9beaa76d6f915d.tar.gz
gst-plugins-bad-2a6ab3709a3997b0b023445d6e9beaa76d6f915d.tar.bz2
gst-plugins-bad-2a6ab3709a3997b0b023445d6e9beaa76d6f915d.zip
test and define HAVE_XSHM build ximage plugin
Original commit message from CVS: test and define HAVE_XSHM build ximage plugin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ce7f3a09..e4952202 100644
--- a/configure.ac
+++ b/configure.ac
@@ -520,6 +520,13 @@ GST_CHECK_FEATURE(XVIDEO, [X11 XVideo extensions], xvideosink-Xv, [
fi
])
+dnl check for XShm
+translit(dnm, m, l) AM_CONDITIONAL(USE_XSHM, true)
+GST_CHECK_FEATURE(XSHM, [X11 Shared Memory], ximage, [
+ AC_CHECK_HEADER(X11/extensions/XShm.h,
+ HAVE_XSHM=yes, HAVE_XSHM=no)
+])
+
dnl Next, check for the optional libraries:
dnl These are all libraries used in building plug-ins
dnl ================================================
@@ -1330,6 +1337,7 @@ sys/v4l/Makefile
sys/v4l2/Makefile
sys/vcd/Makefile
sys/xvideo/Makefile
+sys/ximage/Makefile
sys/glsink/Makefile
ext/Makefile
ext/a52dec/Makefile