summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2005-03-26 11:03:42 +0000
committerTim-Philipp Müller <tim@centricular.net>2005-03-26 11:03:42 +0000
commit5ec0afeace34833e12601072c5ec7ded3c81d702 (patch)
treeec677714c4c5714f0dc24c828a4195959f4ed89b /configure.ac
parenta587eb0e3849a4937889cb14bdd14f677ad66c59 (diff)
downloadgst-plugins-bad-5ec0afeace34833e12601072c5ec7ded3c81d702.tar.gz
gst-plugins-bad-5ec0afeace34833e12601072c5ec7ded3c81d702.tar.bz2
gst-plugins-bad-5ec0afeace34833e12601072c5ec7ded3c81d702.zip
Add new libcdio-based cddasrc plugin (fixes #171530)
Original commit message from CVS: Add new libcdio-based cddasrc plugin (fixes #171530)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7ca63562..5bcdce4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -855,6 +855,14 @@ GST_CHECK_FEATURE(CDAUDIO, [cdaudio], cdaudio, [
AC_SUBST(CDAUDIO_LIBS)
])
+dnl *** cdio ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_CDIO, true)
+GST_CHECK_FEATURE(CDIO, [cdio library], cdio, [
+ PKG_CHECK_MODULES(CDIO, libcdio >= 0.71, HAVE_CDIO=yes, HAVE_CDIO=no)
+ AC_SUBST(CDIO_CFLAGS)
+ AC_SUBST(CDIO_LIBS)
+])
+
dnl *** CDParanoia ***
translit(dnm, m, l) AM_CONDITIONAL(USE_CDPARANOIA, true)
@@ -2053,6 +2061,7 @@ ext/audiofile/Makefile
ext/audioresample/Makefile
ext/cairo/Makefile
ext/cdaudio/Makefile
+ext/cdio/Makefile
ext/cdparanoia/Makefile
ext/dirac/Makefile
ext/directfb/Makefile