summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-10-20 13:51:27 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-10-20 13:51:27 +0000
commit7b2cf1992a48fd2027264b86b26549f792b2a8e4 (patch)
treecef87ed8d42fa2116c37d7a8775961312a743be1 /configure.ac
parentc66fd147bfe3f54369768c2334310c9ee005b6bb (diff)
downloadgst-plugins-bad-7b2cf1992a48fd2027264b86b26549f792b2a8e4.tar.gz
gst-plugins-bad-7b2cf1992a48fd2027264b86b26549f792b2a8e4.tar.bz2
gst-plugins-bad-7b2cf1992a48fd2027264b86b26549f792b2a8e4.zip
fix the build
Original commit message from CVS: fix the build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 24 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 4456264b..d018daa1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1382,11 +1382,30 @@ GST_CHECK_FEATURE(PANGO, [pango], pango, [
AC_SUBST(PANGO_LIBS)
])
-dnl *** raw1394 ***
-translit(dnm, m, l) AM_CONDITIONAL(USE_RAW1394, true)
-GST_CHECK_FEATURE(RAW1394, [raw1394 library], dv1394src, [
- GST_CHECK_LIBHEADER(RAW1394, raw1394, raw1394_new_handle,, libraw1394/raw1394.h, RAW1394_LIBS="-lraw1394")
- AC_SUBST(RAW1394_LIBS)
+dnl *** dv1394 ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_DV1394, true)
+GST_CHECK_FEATURE(DV1394, [raw1394 and avc1394 library], dv1394src, [
+ dnl we need to test three headers and three libs
+ GST_CHECK_LIBHEADER(RAW1394,
+ raw1394, raw1394_new_handle,,
+ libraw1394/raw1394.h, RAW1394_LIBS="-lraw1394")
+ GST_CHECK_LIBHEADER(AVC1394,
+ avc1394, avc1394_send_command, $RAW1394_LIBS,
+ libavc1394/avc1394.h, AVC1394_LIBS="-lavc1394")
+ GST_CHECK_LIBHEADER(ROM1394,
+ rom1394, rom1394_free_directory, $RAW1394_LIBS,
+ libavc1394/rom1394.h, ROM1394_LIBS="-lrom1394")
+
+ dnl now see how far we got
+ if test x$HAVE_RAW1394 = xyes && \
+ test x$HAVE_AVC1394 = xyes && \
+ test x$HAVE_ROM1394 = xyes; then
+ HAVE_DV1394=yes
+ DV1394_LIBS="$RAW1394_LIBS $AVC1394_LIBS $ROM1394_LIBS"
+ AC_SUBST(DV1394_LIBS)
+ else
+ HAVE_DV1394=no
+ fi
])
dnl *** SDL ***