summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Simon <jsimon13@yahoo.fr>2004-01-18 20:19:44 +0000
committerJeremy Simon <jsimon13@yahoo.fr>2004-01-18 20:19:44 +0000
commitb1e81d454192223e58f3225aa44785e940a90fd7 (patch)
tree15eb18d0c8dc1bdf9290d0c134daa40d9f100267 /configure.ac
parentbed2cb631dd5c4cd84402b3ec6ee302f6bdbf62b (diff)
downloadgst-plugins-bad-b1e81d454192223e58f3225aa44785e940a90fd7.tar.gz
gst-plugins-bad-b1e81d454192223e58f3225aa44785e940a90fd7.tar.bz2
gst-plugins-bad-b1e81d454192223e58f3225aa44785e940a90fd7.zip
Check for libmusicbrainz
Original commit message from CVS: Check for libmusicbrainz Add the musicbrainz directory to the build process Update Changelog
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index af1fef40..230d708b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1195,6 +1195,15 @@ main (int argc,
fi
])
+dnl *** musicbrainz ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_MUSICBRAINZ, true)
+GST_CHECK_FEATURE(MUSICBRAINZ, [musicbrainz], musicbrainz, [
+ PKG_CHECK_MODULES(MUSICBRAINZ, libmusicbrainz,
+ HAVE_MUSICBRAINZ="yes", HAVE_MUSICBRAINZ="no")
+ AC_SUBST(MUSICBRAINZ_CFLAGS)
+ AC_SUBST(MUSICBRAINZ_LIBS)
+])
+
dnl *** pango ***
translit(dnm, m, l) AM_CONDITIONAL(USE_PANGO, true)
GST_CHECK_FEATURE(PANGO, [pango], pango, [
@@ -1634,6 +1643,7 @@ ext/mikmod/Makefile
ext/mpeg2dec/Makefile
ext/mpeg2enc/Makefile
ext/mplex/Makefile
+ext/musicbrainz/Makefile
ext/ogg/Makefile
ext/pango/Makefile
ext/raw1394/Makefile