summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerabbas@merali.org>2005-07-15 15:25:36 +0000
committerZaheer Abbas Merali <zaheerabbas@merali.org>2005-07-15 15:25:36 +0000
commitd5783d006813ed270c32e60cb6480d449a72d312 (patch)
tree49d3e5caca95be03badfacf787e1c29af655ccb6 /configure.ac
parent161ddbde0e9eb3fbe10aed0f31bfbcda70af163c (diff)
downloadgst-plugins-bad-d5783d006813ed270c32e60cb6480d449a72d312.tar.gz
gst-plugins-bad-d5783d006813ed270c32e60cb6480d449a72d312.tar.bz2
gst-plugins-bad-d5783d006813ed270c32e60cb6480d449a72d312.zip
Use xfixes's .pc file instead of the header check
Original commit message from CVS: 2005-07-15 Zaheer Abbas Merali <zaheerabbas at merali dot org> * configure.ac: * sys/ximage/Makefile.am: Use xfixes's .pc file instead of the header check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 3 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 150b03e1..78832811 100644
--- a/configure.ac
+++ b/configure.ac
@@ -626,14 +626,9 @@ GST_CHECK_FEATURE(X, [X libraries and plugins],
AC_SUBST(X_CFLAGS)
AC_SUBST(X_LIBS)
dnl check for Xfixes
- AC_CHECK_HEADERS(X11/extensions/Xfixes.h, HAVE_XFIXES="yes", HAVE_XFIXES="no", [#include <X11/Xlib.h>])
- if test "x$HAVE_XFIXES" = "xno"
- then
- AC_MSG_NOTICE([cannot find XFixes development files])
- else
- XFIXES_LIBS="-lXfixes"
- AC_SUBST(XFIXES_LIBS)
- fi
+ PKG_CHECK_MODULES(XFIXES, xfixes, HAVE_XFIXES="yes", HAVE_XFIXES="no")
+ AC_SUBST(XFIXES_LIBS)
+ AC_SUBST(XFIXES_CFLAGS)
AM_CONDITIONAL(HAVE_XFIXES, test "x$HAVE_XFIXES" = "xyes")