summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2002-01-06 19:30:09 +0000
committerWim Taymans <wim.taymans@gmail.com>2002-01-06 19:30:09 +0000
commitd13417cfa213800c0b9f67e1f7fa7c8c9f273a32 (patch)
tree6429307d80bf78cbb162ca2d8ba1448ab8e41f0c /configure.ac
parentdea4419a80b2c88f3685d6bcfbcde6873dd13cdc (diff)
downloadgst-plugins-bad-d13417cfa213800c0b9f67e1f7fa7c8c9f273a32.tar.gz
gst-plugins-bad-d13417cfa213800c0b9f67e1f7fa7c8c9f273a32.tar.bz2
gst-plugins-bad-d13417cfa213800c0b9f67e1f7fa7c8c9f273a32.zip
Added a check for sidplay
Original commit message from CVS: Added a check for sidplay Added a capsfilter example
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 29e0aeeb..f9a0c04d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -570,8 +570,10 @@ dnl *** sidplay ***
dnl FIXME : make this work
translit(dnm, m, l) AM_CONDITIONAL(USE_SIDPLAY, true)
GST_CHECK_FEATURE(SIDPLAY, [sidplay plugin], sidplay, [
- GST_CHECK_LIBHEADER(SIDPLAY, sidplay, sidTune(), ,sidplay/sidtune.h,SIDPLAY_LIBS="-lsidplay")
+ AC_LANG_PUSH(C++)
+ AC_CHECK_HEADER(sidplay/sidtune.h, SIDPLAY_LIBS="-lsidplay", )
AC_SUBST(SIDPLAY_LIBS)
+ AC_LANG_POP()
])
dnl *** smoothwave ***
@@ -1011,6 +1013,7 @@ sys/v4l/Makefile
sys/vcd/Makefile
sys/vga/Makefile
sys/xvideo/Makefile
+examples/capsfilter/Makefile
ext/Makefile
ext/a52dec/Makefile
ext/aalib/Makefile