summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2008-05-07 07:51:36 +0000
committerTim-Philipp Müller <tim@centricular.net>2008-05-07 07:51:36 +0000
commit42d7c3409f0f58e204c57c026fd6333969d50103 (patch)
treeaf9cf81803fe0a2f70cb37c1ec689211d3984be7 /configure.ac
parent75695e03a04fa23f4dbd0264c2ab799859475178 (diff)
downloadgst-plugins-bad-42d7c3409f0f58e204c57c026fd6333969d50103.tar.gz
gst-plugins-bad-42d7c3409f0f58e204c57c026fd6333969d50103.tar.bz2
gst-plugins-bad-42d7c3409f0f58e204c57c026fd6333969d50103.zip
configure.ac: Error out if we don't have the required versions of core/base.
Original commit message from CVS: * configure.ac: Error out if we don't have the required versions of core/base.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index d3335844..c4416ca8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,7 +45,6 @@ AC_LIBTOOL_WIN32_DLL
AM_PROG_LIBTOOL
dnl *** required versions of GStreamer stuff ***
-dnl *** remove rtpmanager stuff below when this is updated
GST_REQ=0.10.19
GSTPB_REQ=0.10.19
@@ -158,12 +157,12 @@ fi
dnl checks for gstreamer
dnl uninstalled is selected preferentially -- see pkg-config(1)
-AG_GST_CHECK_GST($GST_MAJORMINOR, [$GST_REQ])
-AG_GST_CHECK_GST_BASE($GST_MAJORMINOR, [$GST_REQ])
-AG_GST_CHECK_GST_GDP($GST_MAJORMINOR, [$GST_REQ])
+AG_GST_CHECK_GST($GST_MAJORMINOR, [$GST_REQ], yes)
+AG_GST_CHECK_GST_BASE($GST_MAJORMINOR, [$GST_REQ], yes)
+AG_GST_CHECK_GST_GDP($GST_MAJORMINOR, [$GST_REQ], yes)
AG_GST_CHECK_GST_CHECK($GST_MAJORMINOR, [$GST_REQ], no)
-AG_GST_CHECK_GST_CONTROLLER($GST_MAJORMINOR, [$GST_REQ])
-AG_GST_CHECK_GST_PLUGINS_BASE($GST_MAJORMINOR, [$GSTPB_REQ], no)
+AG_GST_CHECK_GST_CONTROLLER($GST_MAJORMINOR, [$GST_REQ], yes)
+AG_GST_CHECK_GST_PLUGINS_BASE($GST_MAJORMINOR, [$GSTPB_REQ], yes)
AM_CONDITIONAL(HAVE_GST_CHECK, test "x$HAVE_GST_CHECK" = "xyes")
GSTPB_PLUGINS_DIR=`$PKG_CONFIG gstreamer-plugins-base-$GST_MAJORMINOR --variable pluginsdir`