summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Smith <msmith@xiph.org>2008-08-20 21:44:22 +0000
committerMichael Smith <msmith@xiph.org>2008-08-20 21:44:22 +0000
commit5c2b8e80444013268fb11c46e1961b39ca307c76 (patch)
tree9cfe01355e9c1564f3528a62b42942d15c82fbd8 /configure.ac
parente2c08fe7360b03477ccbeef57dab648cfe2874aa (diff)
downloadgst-plugins-bad-5c2b8e80444013268fb11c46e1961b39ca307c76.tar.gz
gst-plugins-bad-5c2b8e80444013268fb11c46e1961b39ca307c76.tar.bz2
gst-plugins-bad-5c2b8e80444013268fb11c46e1961b39ca307c76.zip
Add new windows ACM encoder wrapper.
Original commit message from CVS: * configure.ac: * sys/Makefile.am: * sys/acmenc/Makefile.am: * sys/acmenc/acmenc.c: Add new windows ACM encoder wrapper.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eac91a3b..f40ef1f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -238,6 +238,7 @@ dnl *** plug-ins to include ***
dnl these are all the gst plug-ins, compilable without additional libs
AG_GST_CHECK_PLUGIN(app)
+AG_GST_CHECK_PLUGIN(apex)
AG_GST_CHECK_PLUGIN(bayer)
AG_GST_CHECK_PLUGIN(cdxaparse)
AG_GST_CHECK_PLUGIN(deinterlace)
@@ -1126,6 +1127,14 @@ AG_GST_CHECK_FEATURE(WININET, [Windows internet library], wininet, [
[HAVE_WININET="yes"], [HAVE_WININET="no"])
])
+dnl *** acm ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_ACM, true)
+AG_GST_CHECK_FEATURE(ACM, [Windows ACM library], acm, [
+ AC_MSG_CHECKING([Checking for ACM support])
+ AC_CHECK_HEADERS([windows.h msacm.h],
+ [HAVE_ACM="yes"], [HAVE_ACM="no"])
+])
+
else
dnl not building plugins with external dependencies,
@@ -1174,6 +1183,7 @@ AM_CONDITIONAL(USE_X264, false)
AM_CONDITIONAL(USE_XVID, false)
AM_CONDITIONAL(USE_WILDMIDI, false)
AM_CONDITIONAL(USE_WININET, false)
+AM_CONDITIONAL(USE_ACM, false)
fi dnl of EXT plugins
@@ -1237,6 +1247,7 @@ AC_CONFIG_FILES(
Makefile
gst-plugins-bad.spec
gst/Makefile
+gst/apex/Makefile
gst/app/Makefile
gst/bayer/Makefile
gst/cdxaparse/Makefile
@@ -1276,6 +1287,7 @@ gst-libs/gst/app/Makefile
gst-libs/gst/dshow/Makefile
sys/Makefile
sys/dshowdecwrapper/Makefile
+sys/acmenc/Makefile
sys/dshowsrcwrapper/Makefile
sys/dshowvideosink/Makefile
sys/dvb/Makefile
@@ -1308,6 +1320,7 @@ ext/ladspa/Makefile
ext/libmms/Makefile
ext/Makefile
ext/nas/Makefile
+ext/mozilla/Makefile
ext/mpeg2enc/Makefile
ext/mplex/Makefile
ext/musepack/Makefile