summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-03-21 14:50:41 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-03-21 14:50:41 +0000
commit5f1bb9fd9cb04e9c54ee9f80600a3458e5854d44 (patch)
tree257c73c53447c039fcec1403cc6127c33823c211 /configure.ac
parent29d918352b94957160a9be04dac076f2aca2c5d7 (diff)
downloadgst-plugins-bad-5f1bb9fd9cb04e9c54ee9f80600a3458e5854d44.tar.gz
gst-plugins-bad-5f1bb9fd9cb04e9c54ee9f80600a3458e5854d44.tar.bz2
gst-plugins-bad-5f1bb9fd9cb04e9c54ee9f80600a3458e5854d44.zip
configure.ac: Check if the compiler supports do { } while (0) macros. This fixes a warning when compiling with g++ 4....
Original commit message from CVS: * configure.ac: Check if the compiler supports do { } while (0) macros. This fixes a warning when compiling with g++ 4.3, resulting in a build failure because of -Werror. * ext/mpeg2enc/gstmpeg2encpicturereader.cc: * ext/mplex/gstmplex.cc: Include <string.h> for memcpy and friends to fix the build with gcc 4.3. * tests/check/Makefile.am: Remove trailing backslash.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 10372ef1..2d8f9310 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,6 +107,9 @@ AS_PROG_OBJC
dnl check if the compiler supports '-c' and '-o' options
AM_PROG_CC_C_O
+dnl check if the compiler supports do while(0) macros
+AG_GST_CHECK_DOWHILE_MACROS
+
AC_PATH_PROG(VALGRIND_PATH, valgrind, no)
AM_CONDITIONAL(HAVE_VALGRIND, test ! "x$VALGRIND_PATH" = "xno")