summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@gmail.com>2008-07-04 18:52:37 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-07-04 18:52:37 +0000
commit60128149f864acead0cb0b552033c44f5519be32 (patch)
tree8e8d54dc5716af1b8e710b35d8d70b25f627c11c /configure.ac
parent1f25b18c45770894988fa8914e6cd905c4f81fa3 (diff)
downloadgst-plugins-bad-60128149f864acead0cb0b552033c44f5519be32.tar.gz
gst-plugins-bad-60128149f864acead0cb0b552033c44f5519be32.tar.bz2
gst-plugins-bad-60128149f864acead0cb0b552033c44f5519be32.zip
configure.ac: Fix checking of headers for the OSS4 plugin to fail if a single header doesn't exist already. AC_CHECK_...
Original commit message from CVS: Patch by: Damien Lespiau <damien dot lespiau at gmail dot com> * configure.ac: Fix checking of headers for the OSS4 plugin to fail if a single header doesn't exist already. AC_CHECK_HEADERS only fails if none of the headers is found. Fixes bug #541543.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ab215942..e74fee1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1083,7 +1083,8 @@ translit(dnm, m, l) AM_CONDITIONAL(USE_OSS4, true)
AG_GST_CHECK_FEATURE(OSS4, [Open Sound System 4], oss4, [
AC_MSG_CHECKING([Checking if we can build the OSS4 elements])
AC_CHECK_HEADERS([fcntl.h sys/ioctl.h sys/stat.h sys/types.h],
- [HAVE_OSS4="yes"], [HAVE_OSS4="no"])
+ [test -z "$OSS4_MISSING_HEADER" && HAVE_OSS4="yes"],
+ [OSS4_MISSING_HEADER="yes";HAVE_OSS4="no"])
])
dnl *** wininet ***