summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-08-02 17:39:13 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-08-02 17:39:13 +0000
commit81717e11be8210ab758989639c34824bdcf2a33a (patch)
treeb2ec3a097a1723f05567d45d6aa823491e6102d2 /configure.ac
parentf783ef73b7d56aa049717fc5fcaff8add912f550 (diff)
downloadgst-plugins-bad-81717e11be8210ab758989639c34824bdcf2a33a.tar.gz
gst-plugins-bad-81717e11be8210ab758989639c34824bdcf2a33a.tar.bz2
gst-plugins-bad-81717e11be8210ab758989639c34824bdcf2a33a.zip
Add TwoLAME MP2 encoding element, based on the LAME element.
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/twolame/Makefile.am: * ext/twolame/gsttwolame.c: (gst_two_lame_mode_get_type), (gst_two_lame_padding_get_type), (gst_two_lame_emphasis_get_type), (gst_two_lame_release_memory), (gst_two_lame_finalize), (gst_two_lame_base_init), (gst_two_lame_class_init), (gst_two_lame_src_setcaps), (gst_two_lame_sink_setcaps), (gst_two_lame_init), (gst_two_lame_set_property), (gst_two_lame_get_property), (gst_two_lame_sink_event), (gst_two_lame_chain), (gst_two_lame_setup), (gst_two_lame_change_state), (gst_two_lame_get_default_settings), (plugin_init): * ext/twolame/gsttwolame.h: Add TwoLAME MP2 encoding element, based on the LAME element.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d2602a90..6cc8aac1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -972,6 +972,18 @@ AG_GST_CHECK_FEATURE(WILDMIDI, [wildmidi midi soft synth plugin], wildmidi, [
AC_SUBST(WILDMIDI_LIBS)
])
+dnl *** twolame ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_TWOLAME, true)
+AG_GST_CHECK_FEATURE(TWOLAME, [twolame], twolame, [
+ PKG_CHECK_MODULES(TWOLAME, twolame >= 0.3.0, [
+ HAVE_TWOLAME="yes"], [
+ HAVE_TWOLAME="no"
+ AC_MSG_RESULT(no)
+ ])
+ AC_SUBST(TWOLAME_CFLAGS)
+ AC_SUBST(TWOLAME_LIBS)
+])
+
dnl *** SDL ***
translit(dnm, m, l) AM_CONDITIONAL(USE_SDL, true)
AG_GST_CHECK_FEATURE(SDL, [SDL plug-in], sdlvideosink sdlaudiosink, [
@@ -1137,6 +1149,7 @@ AM_CONDITIONAL(USE_NAS, false)
AM_CONDITIONAL(USE_NEON, false)
AM_CONDITIONAL(USE_OFA, false)
AM_CONDITIONAL(USE_OSS4, false)
+AM_CONDITIONAL(USE_TWOLAME, false)
AM_CONDITIONAL(USE_SDL, false)
AM_CONDITIONAL(USE_SNDFILE, false)
AM_CONDITIONAL(USE_SOUNDTOUCH, false)
@@ -1290,6 +1303,7 @@ ext/mythtv/Makefile
ext/neon/Makefile
ext/ofa/Makefile
ext/resindvd/Makefile
+ext/twolame/Makefile
ext/sdl/Makefile
ext/sndfile/Makefile
ext/soundtouch/Makefile