summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVincent Torri <vtorri@univ-evry.fr>2007-01-03 19:54:33 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-01-03 19:54:33 +0000
commite163953b0e1c80aab8622cc0ec5ed567da8097c1 (patch)
tree44aab9ef7ea0673e97cb433f4853b910da9b9025 /configure.ac
parent9b1bffb45607c0cdfc80d1c856d331789789cd34 (diff)
downloadgst-plugins-bad-e163953b0e1c80aab8622cc0ec5ed567da8097c1.tar.gz
gst-plugins-bad-e163953b0e1c80aab8622cc0ec5ed567da8097c1.tar.bz2
gst-plugins-bad-e163953b0e1c80aab8622cc0ec5ed567da8097c1.zip
Add directdrawsink to build and dist it, so it gets built when compiling with MingW on win32 and the required headers...
Original commit message from CVS: Patch by: Vincent Torri <vtorri at univ-evry fr> * configure.ac: * sys/Makefile.am: * sys/directdraw/Makefile.am: Add directdrawsink to build and dist it, so it gets built when compiling with MingW on win32 and the required headers and libraries are available (fixes: #392313). * sys/directdraw/gstdirectdrawsink.c: (gst_directdrawsink_center_rect), (gst_directdrawsink_show_frame), (gst_directdrawsink_setup_ddraw), (gst_directdrawsink_surface_create): Comment out some unused things and fix some printf format issues in order to avoid warnings when buildling with MingW (#392313).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 37 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7a1bcd8e..0a6131dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -280,6 +280,42 @@ GST_CHECK_FEATURE(X, [X libraries and plugins],
CPPFLAGS="$ac_cppflags_save"
])
+dnl DirectDraw
+translit(dnm, m, l) AM_CONDITIONAL(USE_DIRECTDRAW, true)
+GST_CHECK_FEATURE(DIRECTDRAW, [DirectDraw plug-in], directdrawsink, [
+ HAVE_DIRECTDRAW="no"
+ AC_CHECK_HEADERS(windows.h ddraw.h, have_ddraw_headers="yes", have_ddraw_headers="no")
+ if test "x$have_ddraw_headers" = "xyes" ; then
+ save_LIBS="$LIBS"
+ LIBS="$LIBS -lddraw -lgdi32"
+ AC_MSG_CHECKING(for DirectDraw LDFLAGS)
+ AC_LINK_IFELSE([
+#include <windows.h>
+#include <ddraw.h>
+
+int main ()
+{
+ GetStockObject(0);
+ DirectDrawCreate(NULL, NULL, NULL);
+
+ return 0;
+}
+],
+ HAVE_DIRECTDRAW="yes",
+ HAVE_DIRECTDRAW="no")
+ AC_MSG_RESULT($HAVE_DIRECTDRAW)
+ LIBS=$save_LIBS
+ fi
+
+ if test "x$HAVE_DIRECTDRAW" = "xyes"; then
+ dnl this is much more than we want
+ DIRECTDRAW_LIBS="-lddraw -lgdi32"
+ AC_SUBST(DIRECTDRAW_CFLAGS)
+ AC_SUBST(DIRECTDRAW_LIBS)
+ fi
+ AC_SUBST(HAVE_DIRECTDRAW)
+])
+
dnl *** ext plug-ins ***
dnl keep this list sorted alphabetically !
@@ -851,6 +887,7 @@ gst-libs/gst/Makefile
sys/Makefile
sys/glsink/Makefile
sys/dvb/Makefile
+sys/directdraw/Makefile
examples/Makefile
examples/directfb/Makefile
ext/amrwb/amrwb-code/Makefile