summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2004-01-30 20:23:23 +0000
committerBenjamin Otte <otte@gnome.org>2004-01-30 20:23:23 +0000
commit28d6dd44a86af1f1f41becbf0cca954e29949571 (patch)
treec6ae53e036ffb8d5ed0364bd78de74c384f920fd /configure.ac
parent4ee5e3e7db8e375c6ff3cb4d17b56d21bf910ed5 (diff)
downloadgst-plugins-bad-28d6dd44a86af1f1f41becbf0cca954e29949571.tar.gz
gst-plugins-bad-28d6dd44a86af1f1f41becbf0cca954e29949571.tar.bz2
gst-plugins-bad-28d6dd44a86af1f1f41becbf0cca954e29949571.zip
configure.ac: use AC_C_INLINE
Original commit message from CVS: 2004-01-30 Benjamin Otte <in7y118@public.uni-hamburg.de> * configure.ac: use AC_C_INLINE * configure.ac: * ext/Makefile.am: * ext/theora/Makefile.am: * ext/theora/theoradec.c: add theora video decoder. Does just do simple decoding for now and has been tested against Theora cvs only. * ext/vorbis/vorbisdec.c: (vorbis_dec_event): always reset packetno on DISCONT
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0fa8bc55..25a828ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,6 +81,7 @@ AC_PROG_CXXCPP
AC_ISC_POSIX
AC_HEADER_STDC([])
+AC_C_INLINE
dnl Check for a way to display the function name in debug output
GST_CHECK_FUNCTION()
@@ -1333,6 +1334,14 @@ GST_CHECK_FEATURE(OGG, [ogg de/encoder], oggdemux oggmux, [
AS_SCRUB_INCLUDE(OGG_CFLAGS)
])
+dnl *** theora ***
+dnl FIXME: theora doesn't have proper pc/m4 files yet, change this when this happens
+translit(dnm, m, l) AM_CONDITIONAL(USE_THEORA, true)
+GST_CHECK_FEATURE(THEORA, [ogg theora codec], theoradec, [
+ GST_CHECK_LIBHEADER(THEORA, theora, theora_version_string, , theora/theora.h, THEORA_LIBS="-ltheora")
+ AC_SUBST(THEORA_LIBS)
+])
+
dnl *** vorbis ***
dnl AM_PATH_VORBIS only takes two options
translit(dnm, m, l) AM_CONDITIONAL(USE_VORBIS, true)
@@ -1687,8 +1696,9 @@ ext/snapshot/Makefile
ext/speex/Makefile
ext/sndfile/Makefile
ext/swfdec/Makefile
-ext/vorbis/Makefile
ext/tarkin/Makefile
+ext/theora/Makefile
+ext/vorbis/Makefile
ext/xvid/Makefile
gst-libs/Makefile
gst-libs/gst/Makefile