summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2005-06-29 16:14:29 +0000
committerAndy Wingo <wingo@pobox.com>2005-06-29 16:14:29 +0000
commit41c2f11dd4fd91a791f6077f4ed531662258c5eb (patch)
tree1270e331cd5f8e3a1c744ffcfecfbe4895bfb755 /configure.ac
parent51b0a88ebbb3096764d1e0edb7398c31023b9583 (diff)
downloadgst-plugins-bad-41c2f11dd4fd91a791f6077f4ed531662258c5eb.tar.gz
gst-plugins-bad-41c2f11dd4fd91a791f6077f4ed531662258c5eb.tar.bz2
gst-plugins-bad-41c2f11dd4fd91a791f6077f4ed531662258c5eb.zip
configure.ac (GST_CFLAGS): GCC strikes back!!! Let the build breakage ensue!!!
Original commit message from CVS: 2005-06-29 Andy Wingo <wingo@pobox.com> * configure.ac (GST_CFLAGS): GCC strikes back!!! Let the build breakage ensue!!! * gst/rtsp/gstrtspsrc.c (gst_rtspsrc_loop, gst_rtspsrc_open): Signedness, unused var fixes. (gst_rtspsrc_close): Unused? * gst/realmedia/rmdemux.c (re_hexdump_bytes): Unused. * gst/law/mulaw-encode.c (gst_mulawenc_chain): Signeness fix. * gst/law/alaw-encode.c (alawenc_getcaps): Remove unneeded declarations. Typo (probably crasher) fix. * gst/law/mulaw-encode.c (mulawdec_getcaps): * gst/law/mulaw-encode.c (mulawenc_getcaps): * gst/law/alaw-decode.c (alawdec_getcaps): Same crasher fix. * gst/goom/gstgoom.c (gst_goom_init): Hook up the event function. * gst/effectv/gstwarp.c (gst_warptv_setup): Signedness fix. * gst/effectv/gstdice.c (gst_dicetv_draw): Um, deferencing uninitialized pointer not good. * gst/videofilter/gstvideoexample.c (plugin_init): * gst/videofilter/Makefile.am (libgstvideoexample_la_LIBADD): Link to libgstvideofilter instead of gst_library_load. * gst/alpha/gstalpha.c (gst_alpha_chroma_key_i420) (gst_alpha_chroma_key_ayuv): Signedness fixen.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b100287..6864b295 100644
--- a/configure.ac
+++ b/configure.ac
@@ -439,6 +439,8 @@ GST_CHECK_FEATURE(ESD, [esound plug-ins], esdsink, [
])
])
+GST_CFLAGS="$GST_CFLAGS $GST_ERROR"
+
AC_SUBST(GST_LIBS)
AC_SUBST(GST_CFLAGS)