summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2002-03-18 04:41:35 +0000
committerAndy Wingo <wingo@pobox.com>2002-03-18 04:41:35 +0000
commit62c2ffe709c84bed65051e2b40f0322e79db8af8 (patch)
treefac5d59752e0d055a021dfc142d5cedea08b7fc1 /configure.ac
parent1e0d80ab837e0db1c78dd415b62d5ba2d876f763 (diff)
downloadgst-plugins-bad-62c2ffe709c84bed65051e2b40f0322e79db8af8.tar.gz
gst-plugins-bad-62c2ffe709c84bed65051e2b40f0322e79db8af8.tar.bz2
gst-plugins-bad-62c2ffe709c84bed65051e2b40f0322e79db8af8.zip
s/gst_element_install_std_props/gst_element_class_install_std_props/ -- it just makes more sense that way added jack ...
Original commit message from CVS: * s/gst_element_install_std_props/gst_element_class_install_std_props/ -- it just makes more sense that way * added jack element, doesn't quite work right yet but i didn't want to lose the work -- it does build, register, and attempt to run though * imposed some restrictions on the naming of request pads to better allow for reverse parsing * added '%s' to reverse parsing * added new bin flag to indicate that it is self-iterating, and some lame code in gst-launch to test it out * fixen on launch-gui * added pkg-config stuff for the editor's libs
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 19 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 5bca237d..67b17422 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,7 +10,7 @@ AM_DISABLE_STATIC
dnl when going to/from release please set the nano (fourth number) right !
dnl We disable static building for development, for time savings
AM_DISABLE_STATIC
-AS_VERSION(gst-plugins, GST_PLUGINS, 0, 3, 2, 2)
+AS_VERSION(gst-plugins, GST_PLUGINS, 0, 3, 3, 1)
AM_INIT_AUTOMAKE($PACKAGE,$VERSION)
AS_LIBTOOL(GST_PLUGINS, 0, 0, 0, yes)
@@ -426,6 +426,23 @@ GST_CHECK_FEATURE(HTTP, [http plugins], gsthttpsrc, [
AC_SUBST(GST_HTTPSRC_GET_TYPE)
])
+dnl *** Jack ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_JACK, true)
+GST_CHECK_FEATURE(JACK, Jack, jack, [
+ PKG_CHECK_MODULES(JACK, jack, HAVE_JACK="yes", HAVE_JACK="no")
+ AC_SUBST(JACK_CFLAGS)
+ AC_SUBST(JACK_LIBS)
+])
+
+dnl *** jpeg ***
+dnl FIXME: we could use header checks here as well IMO
+translit(dnm, m, l) AM_CONDITIONAL(USE_JPEG, true)
+GST_CHECK_FEATURE(JPEG, [jpeg], jpegenc jpegdec, [
+ AC_CHECK_LIB(jpeg, jpeg_set_defaults, HAVE_JPEG="yes", HAVE_JPEG="no")
+ JPEG_LIBS="-ljpeg"
+ AC_SUBST(JPEG_LIBS)
+])
+
dnl *** lame ***
translit(dnm, m, l) AM_CONDITIONAL(USE_LAME, true)
GST_CHECK_FEATURE(LAME, [lame mp3 encoder library], lame, [
@@ -433,22 +450,12 @@ GST_CHECK_LIBHEADER(LAME, mp3lame, lame_init, -lm, lame/lame.h, HAVE_LAME="yes"
])
AC_SUBST(LAME_LIBS)
-
dnl FIXME : check if these CPP flags can be dealt with otherwise
dnl libdvcheck_save_CPPFLAGS="$CPPFLAGS"
dnl CPPFLAGS="$CPPFLAGS $GST_CFLAGS"
dnl AC_CHECK_HEADER(libdv/dv.h, :, HAVE_LIBDV=no)
dnl CPPFLAGS="$libdvcheck_save_CPPFLAGS"
-dnl *** jpeg ***
-dnl FIXME: we could use header checks here as well IMO
-translit(dnm, m, l) AM_CONDITIONAL(USE_JPEG, true)
-GST_CHECK_FEATURE(JPEG, [jpeg], jpegenc jpegdec, [
- AC_CHECK_LIB(jpeg, jpeg_set_defaults, HAVE_JPEG="yes", HAVE_JPEG="no")
- JPEG_LIBS="-ljpeg"
- AC_SUBST(JPEG_LIBS)
-])
-
dnl *** mad ***
dnl FIXME: we could use header checks here as well IMO
translit(dnm, m, l) AM_CONDITIONAL(USE_MAD, true)
@@ -780,6 +787,7 @@ ext/gnomevfs/Makefile
ext/gsm/Makefile
ext/hermes/Makefile
ext/http/Makefile
+ext/jack/Makefile
ext/jpeg/Makefile
ext/ladspa/Makefile
ext/lame/Makefile