summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2005-08-02 11:42:33 +0000
committerEdward Hervey <bilboed@bilboed.com>2005-08-02 11:42:33 +0000
commit63d0089f78fdf83900a4c68f9d4ecdaec1420ed8 (patch)
tree8856381563ca2b196e7508cd0e5dbc49ee95b830 /configure.ac
parent4227b442c6698b4cc30aa2965bffd78577bacc0b (diff)
downloadgst-plugins-bad-63d0089f78fdf83900a4c68f9d4ecdaec1420ed8.tar.gz
gst-plugins-bad-63d0089f78fdf83900a4c68f9d4ecdaec1420ed8.tar.bz2
gst-plugins-bad-63d0089f78fdf83900a4c68f9d4ecdaec1420ed8.zip
Ported pngenc , still have to port pngdec...
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/libpng/Makefile.am: * ext/libpng/gstpng.c: * ext/libpng/gstpngenc.c: Ported pngenc , still have to port pngdec...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7a1e22bc..21eb8c88 100644
--- a/configure.ac
+++ b/configure.ac
@@ -519,6 +519,16 @@ GST_CHECK_FEATURE(ESD, [esound plug-ins], esdsink, [
])
])
+dnl *** libpng ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_LIBPNG, true)
+GST_CHECK_FEATURE(LIBPNG, [libpng PNG encoder], pngenc, [
+ PKG_CHECK_MODULES(LIBPNG, libpng12, HAVE_LIBPNG="yes", HAVE_LIBPNG="no")
+ AC_SUBST(LIBPNG_CFLAGS)
+ AC_SUBST(LIBPNG_LIBS)
+])
+
+
+
dnl also add builddir include for enumtypes and marshal
GST_CFLAGS="-I\$(top_srcdir)/gst-libs -I\$(top_builddir)/gst-libs $GST_CFLAGS $GST_ERROR"
@@ -600,6 +610,7 @@ ext/aalib/Makefile
ext/dv/Makefile
ext/gconf/Makefile
ext/libcaca/Makefile
+ext/libpng/Makefile
ext/mad/Makefile
ext/raw1394/Makefile
ext/shout2/Makefile