summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2005-07-08 10:47:28 +0000
committerAndy Wingo <wingo@pobox.com>2005-07-08 10:47:28 +0000
commitae4309d00ca64b72be1327e166c00324656f8f82 (patch)
tree4b9d7a19ed4889cbe30a761fca8dd2e67252a9bc /configure.ac
parent1c1a9dd6aaad300daca94549f9cff3b9dc61dd7f (diff)
downloadgst-plugins-bad-ae4309d00ca64b72be1327e166c00324656f8f82.tar.gz
gst-plugins-bad-ae4309d00ca64b72be1327e166c00324656f8f82.tar.bz2
gst-plugins-bad-ae4309d00ca64b72be1327e166c00324656f8f82.zip
gst/avi/Makefile.am (libgstavi_la_CFLAGS): No gettext hacks, the defines come from config.h.
Original commit message from CVS: 2005-07-08 Andy Wingo <wingo@pobox.com> * gst/avi/Makefile.am (libgstavi_la_CFLAGS): No gettext hacks, the defines come from config.h. * autogen.sh: Run autopoint, etc. * Makefile.am (DIST_SUBDIRS, SUBDIRS): Go into po/. * configure.ac: Add gettext stuff.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac62
1 files changed, 34 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index 86879183..1d91f9a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,14 +46,19 @@ AM_PROG_AS
AS="${CC}"
AS_PROG_OBJC
-dnl the gettext stuff needed
-dnl AM_GNU_GETTEXT_VERSION(0.11.5)
-dnl AM_GNU_GETTEXT([external])
-
-dnl GETTEXT_PACKAGE=gst-plugins-$GST_MAJORMINOR
-dnl AC_SUBST(GETTEXT_PACKAGE)
-dnl AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], "$GETTEXT_PACKAGE",
-dnl [gettext package name])
+the gettext stuff needed
+AM_GNU_GETTEXT_VERSION(0.11.5)
+AM_GNU_GETTEXT([external])
+
+GETTEXT_PACKAGE=gst-plugins-$GST_MAJORMINOR
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], "$GETTEXT_PACKAGE",
+ [gettext package name])
+
+dnl define LOCALEDIR in config.h
+AS_AC_EXPAND(LOCALEDIR, $datadir/locale)
+AC_DEFINE_UNQUOTED([LOCALEDIR], "$LOCALEDIR",
+ [gettext locale dir])
dnl decide on error flags
AS_COMPILER_FLAG(-Wall, GST_WALL="yes", GST_WALL="no")
@@ -339,26 +344,26 @@ dnl ============================= sys plug-ins ================================
dnl ==========================================================================
dnl *** OSS audio *** (Linux, *BSD)
-dnl translit(dnm, m, l) AM_CONDITIONAL(USE_OSS, true)
-dnl GST_CHECK_FEATURE(OSS, [OSS audio], osssrc osssink, [
-dnl HAVE_OSS="yes"
- dnl Linux and newer BSD versions :
-dnl AC_CHECK_HEADER(sys/soundcard.h, [
-dnl AC_DEFINE(HAVE_OSS_INCLUDE_IN_SYS,, [Define if OSS includes are in /sys/])
-dnl ] , [
- dnl Some old BSD versions :
-dnl AC_CHECK_HEADER(soundcard.h, [
-dnl AC_DEFINE(HAVE_OSS_INCLUDE_IN_ROOT,, [Define if OSS includes are in /])
-dnl ], [
- dnl Some old BSD versions :
-dnl AC_CHECK_HEADER(machine/soundcard.h, [
-dnl AC_DEFINE(HAVE_OSS_INCLUDE_IN_MACHINE,, [Define if OSS includes are in /machine/])
-dnl ], [
-dnl HAVE_OSS="no"
-dnl ])
-dnl ])
-dnl ])
-dnl ])
+translit(dnm, m, l) AM_CONDITIONAL(USE_OSS, true)
+GST_CHECK_FEATURE(OSS, [OSS audio], osssrc osssink, [
+ HAVE_OSS="yes"
+dnl Linux and newer BSD versions :
+ AC_CHECK_HEADER(sys/soundcard.h, [
+ AC_DEFINE(HAVE_OSS_INCLUDE_IN_SYS,, [Define if OSS includes are in /sys/])
+ ] , [
+dnl Some old BSD versions :
+ AC_CHECK_HEADER(soundcard.h, [
+ AC_DEFINE(HAVE_OSS_INCLUDE_IN_ROOT,, [Define if OSS includes are in /])
+ ], [
+ dnl Some old BSD versions :
+ AC_CHECK_HEADER(machine/soundcard.h, [
+ AC_DEFINE(HAVE_OSS_INCLUDE_IN_MACHINE,, [Define if OSS includes are in /machine/])
+ ], [
+ HAVE_OSS="no"
+ ])
+ ])
+ ])
+])
dnl ###########################
dnl # Configure external libs #
@@ -537,6 +542,7 @@ gst/videofilter/Makefile
gst-libs/Makefile
gst-libs/gst/Makefile
sys/Makefile
+sys/oss/Makefile
ext/Makefile
ext/aalib/Makefile
ext/dv/Makefile