summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2004-06-07 12:01:51 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2004-06-07 12:01:51 +0000
commitc4ce805afa52e3ec5bb1021d9d71cfc787d8f318 (patch)
tree3b7bc37c55e1703ad516e6b23a5f837c814f649c /configure.ac
parent1a0ceb7f99dfa6d1af07d5f2afbf95e11fc835bc (diff)
downloadgst-plugins-bad-c4ce805afa52e3ec5bb1021d9d71cfc787d8f318.tar.gz
gst-plugins-bad-c4ce805afa52e3ec5bb1021d9d71cfc787d8f318.tar.bz2
gst-plugins-bad-c4ce805afa52e3ec5bb1021d9d71cfc787d8f318.zip
AUTHORS: Add me to the authors file
Original commit message from CVS: * AUTHORS: Add me to the authors file * configure.ac: Increase the libdv requirement to >= version 0.100 * ext/dv/gstdvdec.c: (gst_dvdec_init), (gst_dvdec_src_convert), (gst_dvdec_src_query), (gst_dvdec_handle_sink_event), (gst_dvdec_push), (gst_dvdec_loop), (gst_dvdec_change_state): * ext/dv/gstdvdec.h: Add support for the new_media flag when sending DISCONT events Make the querying work when video pad is not linked
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ab517b24..f33696f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1157,7 +1157,7 @@ GST_CHECK_FEATURE(LCS, Lcs, lcs, [
dnl *** libdv ***
translit(dnm, m, l) AM_CONDITIONAL(USE_LIBDV, true)
GST_CHECK_FEATURE(LIBDV, [libdv DV/video decoder], dvdec, [
- PKG_CHECK_MODULES(LIBDV, libdv >= 0.98, HAVE_LIBDV="yes", HAVE_LIBDV="no")
+ PKG_CHECK_MODULES(LIBDV, libdv >= 0.100, HAVE_LIBDV="yes", HAVE_LIBDV="no")
AC_SUBST(LIBDV_CFLAGS)
AC_SUBST(LIBDV_LIBS)
])
@@ -1499,11 +1499,16 @@ GST_CHECK_FEATURE(OGG, [ogg de/encoder], oggdemux oggmux, [
])
dnl *** theora ***
-dnl FIXME: theora doesn't have proper pc/m4 files yet, change this when this happens
translit(dnm, m, l) AM_CONDITIONAL(USE_THEORA, true)
GST_CHECK_FEATURE(THEORA, [ogg theora codec], theoradec, [
- GST_CHECK_LIBHEADER(THEORA, theora, theora_version_string, , theora/theora.h, THEORA_LIBS="-ltheora")
- AC_SUBST(THEORA_LIBS)
+ PKG_CHECK_MODULES(THEORA, theora, [
+ HAVE_THEORA="yes"
+ AC_SUBST(THEORA_LIBS)
+ AC_SUBST(THEORA_CFLAGS)
+ ], [
+ GST_CHECK_LIBHEADER(THEORA, theora, theora_version_string, , theora/theora.h, THEORA_LIBS="-ltheora")
+ AC_SUBST(THEORA_LIBS)
+ ])
])
dnl *** vorbis ***