summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJulien Moutte <julien@moutte.net>2005-11-02 12:43:03 +0000
committerJulien Moutte <julien@moutte.net>2005-11-02 12:43:03 +0000
commitd99ae29b78d8087c426b6132f7c6292240581422 (patch)
tree2971a4f7db8614d7a4dab5b5dd4d3ce351d4632b /configure.ac
parent801be361c18372ec28732ef55212fbbfa9deaf9c (diff)
downloadgst-plugins-bad-d99ae29b78d8087c426b6132f7c6292240581422.tar.gz
gst-plugins-bad-d99ae29b78d8087c426b6132f7c6292240581422.tar.bz2
gst-plugins-bad-d99ae29b78d8087c426b6132f7c6292240581422.zip
Complete rewrite/port of
Original commit message from CVS: 2005-11-02 Julien MOUTTE <julien@moutte.net> * configure.ac: * ext/Makefile.am: * ext/directfb/Makefile.am: * ext/directfb/dfbvideosink.c: (gst_dfbvideosink_get_format_name), (gst_dfbvideosink_surface_create), (gst_dfbvideosink_surface_destroy), (gst_dfbvideosink_event_thread), (gst_dfbvideosink_enum_layers), (gst_dfbvideosink_enum_vmodes), (gst_dfbvideosink_enum_devices), (gst_dfbvideosink_setup), (gst_dfbvideosink_cleanup), (gst_dfbvideosink_get_format_from_caps), (gst_dfbvideosink_get_caps_from_format), (gst_dfbvideosink_can_blit_from_format), (gst_dfbvideosink_get_best_vmode), (gst_dfbvideosink_getcaps), (gst_dfbvideosink_setcaps), (gst_dfbvideosink_change_state), (gst_dfbvideosink_get_times), (gst_dfbvideosink_center_rect), (gst_dfbvideosink_show_frame), (gst_dfbvideosink_bufferpool_clear), (gst_dfbvideosink_buffer_alloc), (gst_dfbsurface_finalize), (gst_dfbsurface_init), (gst_dfbsurface_class_init), (gst_dfbsurface_get_type), (gst_dfbvideosink_interface_supported), (gst_dfbvideosink_interface_init), (gst_dfbvideosink_navigation_send_event), (gst_dfbvideosink_navigation_init), (gst_dfbvideosink_set_property), (gst_dfbvideosink_get_property), (gst_dfbvideosink_init), (gst_dfbvideosink_base_init), (gst_dfbvideosink_class_init), (gst_dfbvideosink_get_type), (plugin_init): * ext/directfb/dfbvideosink.h: * ext/directfb/directfbvideosink.c: * ext/directfb/directfbvideosink.h: Complete rewrite/port of DirectFB video sink to 0.9. Handles reverse negotiation, hardware scaling, navigation, buffer allocation from video memory etc...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3d9c6835..0e53f53a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -324,6 +324,18 @@ dnl ###########################
dnl # Configure external libs #
dnl ###########################
+dnl **** DirectFB ****
+translit(dnm, m, l) AM_CONDITIONAL(USE_DIRECTFB, true)
+GST_CHECK_FEATURE(DIRECTFB, [directfb], dfbvideosink , [
+ PKG_CHECK_MODULES(DIRECTFB, directfb, [
+ HAVE_DIRECTFB="yes"
+ AC_SUBST(DIRECTFB_CFLAGS)
+ AC_SUBST(DIRECTFB_LIBS)
+ ], [
+ HAVE_DIRECTFB="no"
+ ])
+])
+
dnl **** Free AAC Encoder (FAAC) ****
translit(dnm, m, l) AM_CONDITIONAL(USE_FAAC, true)
GST_CHECK_FEATURE(FAAC, [AAC encoder plug-in], faac, [
@@ -470,6 +482,7 @@ gst/qtdemux/Makefile
gst/tta/Makefile
sys/Makefile
ext/Makefile
+ext/directfb/Makefile
ext/faac/Makefile
ext/faad/Makefile
ext/gsm/Makefile