summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2004-02-20 00:52:07 +0000
committerBenjamin Otte <otte@gnome.org>2004-02-20 00:52:07 +0000
commitea5845cb2bfdb57a06cc2ad5b2561889b5fcc049 (patch)
tree9dda208cfb8b9d268abb43c3ac4fb09c3666ca73 /configure.ac
parentfd2dd2337b1b5e466540337dac79a69a560f6eb4 (diff)
downloadgst-plugins-bad-ea5845cb2bfdb57a06cc2ad5b2561889b5fcc049.tar.gz
gst-plugins-bad-ea5845cb2bfdb57a06cc2ad5b2561889b5fcc049.tar.bz2
gst-plugins-bad-ea5845cb2bfdb57a06cc2ad5b2561889b5fcc049.zip
ext/xine/: add first version of xine plugin wrapper. Currently only wraps the
Original commit message from CVS: 2004-02-20 Benjamin Otte <otte@gnome.org> * ext/xine/Makefile.am: * ext/xine/gstxine.h: * ext/xine/xine.c: * ext/xine/xineaudiodec.c: * ext/xine/xinecaps.c: add first version of xine plugin wrapper. Currently only wraps the QDM2 win32 DLL, and even that only in proof-of-concept quality. * configure.ac: * ext/Makefile.am: add xine plugin wrapper, disabled by default. Use --enable-xine to build. Note that it'll segfault on gst-register if you don't remove the goom and tvtime post plugins from xine. * gst/qtdemux/qtdemux.c: (gst_qtdemux_handle_sink_event), (qtdemux_parse), (qtdemux_parse_trak), (qtdemux_audio_caps): add extradata parsing for QDM2. change around debugging prints.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3626b82b..4631797a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1320,6 +1320,14 @@ vorbis_synthesis_restart (v);
CFLAGS="$ac_cflags_save"
fi
+dnl *** xine ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_XINE, true)
+GST_CHECK_FEATURE(XINE, [xine wrapper], xine, [
+ PKG_CHECK_MODULES(XINE, libxine >= 1.0.0, HAVE_XINE=yes, HAVE_XINE=no)
+ AC_SUBST(XINE_CFLAGS)
+ AC_SUBST(XINE_LIBS)
+],disabled)
+
dnl *** XVID ***
translit(dnm, m, l) AM_CONDITIONAL(USE_XVID, true)
GST_CHECK_FEATURE(XVID, [xvid plugins], xvid, [
@@ -1664,6 +1672,7 @@ ext/swfdec/Makefile
ext/tarkin/Makefile
ext/theora/Makefile
ext/vorbis/Makefile
+ext/xine/Makefile
ext/xvid/Makefile
gst-libs/Makefile
gst-libs/gst/Makefile