summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2005-05-06 19:55:22 +0000
committerWim Taymans <wim.taymans@gmail.com>2005-05-06 19:55:22 +0000
commitf9bf6a7731cd64c7213294dbb8ae8196527219a2 (patch)
tree280659ab2e47be6c34250039ca6317fff2c94dab /configure.ac
parentd0556a1534b491e0bf7c420ae4fed0cd79d5a955 (diff)
downloadgst-plugins-bad-f9bf6a7731cd64c7213294dbb8ae8196527219a2.tar.gz
gst-plugins-bad-f9bf6a7731cd64c7213294dbb8ae8196527219a2.tar.bz2
gst-plugins-bad-f9bf6a7731cd64c7213294dbb8ae8196527219a2.zip
Ported 2 more plugins. usgly hack in the Makefile.am though, I'm sure someone will fix it.
Original commit message from CVS: * configure.ac: * ext/aalib/Makefile.am: * ext/aalib/gstaasink.c: (gst_aasink_get_type), (gst_aasink_class_init), (gst_aasink_fixate), (gst_aasink_setcaps), (gst_aasink_init), (gst_aasink_get_times), (gst_aasink_render), (gst_aasink_set_property), (gst_aasink_get_property), (gst_aasink_open), (gst_aasink_close), (gst_aasink_change_state): * ext/aalib/gstaasink.h: * gst/smpte/Makefile.am: * gst/smpte/gstsmpte.c: (gst_smpte_setcaps), (gst_smpte_init), (gst_smpte_collected): * gst/smpte/gstsmpte.h: Ported 2 more plugins. usgly hack in the Makefile.am though, I'm sure someone will fix it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 16 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f2d77f92..e018feb7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -307,7 +307,8 @@ dnl these are all the gst plug-ins, compilable without additional libs
GST_PLUGINS_ALL="\
videofilter \
effectv \
- law"
+ law \
+ smpte"
dnl see if we can build C++ plug-ins
if test "x$HAVE_CXX" = "xyes"; then
@@ -360,16 +361,27 @@ dnl ])
dnl ])
dnl ])
+<<<<<<< configure.ac
+dnl *** aalib ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_AALIB, true)
+GST_CHECK_FEATURE(AALIB, [aasink plug-in], aasink, [
+ AM_PATH_AALIB(, HAVE_AALIB=yes, HAVE_AALIB=no)
+ AS_SCRUB_INCLUDE(AALIB_CFLAGS)
+])
+
+
+=======
dnl ###########################
dnl # Configure external libs #
dnl ###########################
+>>>>>>> 1.538
dnl *** sidplay : works with libsidplay 1.36.x (not 2.x.x) ***
translit(dnm, m, l) AM_CONDITIONAL(USE_SIDPLAY, true)
GST_CHECK_FEATURE(SIDPLAY, [sidplay plug-in], sidplay, [
GST_PATH_SIDPLAY()
- ])
+])
dnl *** mad ***
dnl FIXME: we could use header checks here as well IMO
@@ -446,9 +458,11 @@ gst-plugins.spec
gst/Makefile
gst/effectv/Makefile
gst/law/Makefile
+gst/smpte/Makefile
gst/videofilter/Makefile
sys/Makefile
ext/Makefile
+ext/aalib/Makefile
ext/mad/Makefile
ext/sidplay/Makefile
common/Makefile