summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWouter Cloetens <wouter@mind.be>2007-11-15 17:26:25 +0000
committerWim Taymans <wim.taymans@gmail.com>2007-11-15 17:26:25 +0000
commit03d8e595a047894cbfdb24105d701e3cb6a0551b (patch)
tree98c20604b1a1dd279f4592c2e5eb1b9039f694b5 /configure.ac
parent621a4e4792bbc0d5b3a338024a3ce6c4053177f3 (diff)
downloadgst-plugins-bad-03d8e595a047894cbfdb24105d701e3cb6a0551b.tar.gz
gst-plugins-bad-03d8e595a047894cbfdb24105d701e3cb6a0551b.tar.bz2
gst-plugins-bad-03d8e595a047894cbfdb24105d701e3cb6a0551b.zip
Added HTTP source based on libsoup. Fixes #497020.
Original commit message from CVS: Patch by: Wouter Cloetens <wouter at mind dot be> * configure.ac: * ext/Makefile.am: * ext/soup/Makefile.am: * ext/soup/gstsouphttpsrc.c: (_do_init), (gst_souphttp_src_base_init), (gst_souphttp_src_class_init), (gst_souphttp_src_init), (gst_souphttp_src_dispose), (gst_souphttp_src_set_property), (gst_souphttp_src_get_property), (gst_souphttp_src_create), (gst_souphttp_src_start), (gst_souphttp_src_stop), (gst_souphttp_src_unlock), (gst_souphttp_src_set_location), (soup_got_chunk), (soup_response), (soup_session_close), (plugin_init): * ext/soup/gstsouphttpsrc.h: Added HTTP source based on libsoup. Fixes #497020.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 36b7d7ee..cb60f72f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -779,6 +779,17 @@ AG_GST_CHECK_FEATURE(NEON, [neon http client plugins], neonhttpsrc, [
AC_SUBST(NEON_LIBS)
])
+dnl *** soup ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_SOUP, true)
+AG_GST_CHECK_FEATURE(SOUP, [soup http client plugins], souphttpsrc, [
+ PKG_CHECK_MODULES(SOUP, libsoup-2.2, HAVE_SOUP="yes", [
+ HAVE_SOUP="no"
+ AC_MSG_RESULT(no)
+ ])
+ AC_SUBST(SOUP_CFLAGS)
+ AC_SUBST(SOUP_LIBS)
+])
+
dnl *** timidity ***
translit(dnm, m, l) AM_CONDITIONAL(USE_TIMIDITY, true)
AG_GST_CHECK_FEATURE(TIMIDITY, [timidity midi soft synth plugin], timidity, [
@@ -965,6 +976,7 @@ AM_CONDITIONAL(USE_MUSICBRAINZ, false)
AM_CONDITIONAL(USE_MYTHTV, false)
AM_CONDITIONAL(USE_NAS, false)
AM_CONDITIONAL(USE_NEON, false)
+AM_CONDITIONAL(USE_SOUP, false)
AM_CONDITIONAL(USE_SDL, false)
AM_CONDITIONAL(USE_SNDFILE, false)
AM_CONDITIONAL(USE_SOUNDTOUCH, false)
@@ -1100,6 +1112,7 @@ ext/musepack/Makefile
ext/musicbrainz/Makefile
ext/mythtv/Makefile
ext/neon/Makefile
+ext/soup/Makefile
ext/sdl/Makefile
ext/sndfile/Makefile
ext/soundtouch/Makefile