summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2007-01-05 18:32:03 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-01-05 18:32:03 +0000
commit1bf15564bf9ff6d5e1b70816e80aeae2d2c1e1a8 (patch)
treeb7e28e5cf0e4d03d3a57b971ee2cbdbbb1395a94 /configure.ac
parent5b4a32581104b18d084ff97c65fa91afc653c487 (diff)
downloadgst-plugins-bad-1bf15564bf9ff6d5e1b70816e80aeae2d2c1e1a8.tar.gz
gst-plugins-bad-1bf15564bf9ff6d5e1b70816e80aeae2d2c1e1a8.tar.bz2
gst-plugins-bad-1bf15564bf9ff6d5e1b70816e80aeae2d2c1e1a8.zip
Check for zlib and if available pass it explicitly to the linker when linking qtdemux. If not available (or --disable...
Original commit message from CVS: * configure.ac: * gst/qtdemux/Makefile.am: * gst/qtdemux/qtdemux.c: (qtdemux_parse_moov): Check for zlib and if available pass it explicitly to the linker when linking qtdemux. If not available (or --disable-external has been specified!), disable the bits in qtdemux that use it. Fixes build on MingW (#392856).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6735786f..e0c71400 100644
--- a/configure.ac
+++ b/configure.ac
@@ -821,6 +821,17 @@ GST_CHECK_FEATURE(DVB, [DVB Source], dvb, [
AC_CHECK_HEADER(linux/dvb/frontend.h, [HAVE_DVB="yes"], [HAVE_DVB="no"])
])
+dnl *** qtdemux prefers to have zlib ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_ZLIB, true)
+GST_CHECK_FEATURE(ZLIB, [zlib support for qtdemux],, [
+ GST_CHECK_LIBHEADER(ZLIB,
+ z, uncompress,, zlib.h, [
+ HAVE_ZLIB="yes"
+ ZLIB_LIBS="-lz"
+ AC_SUBST(ZLIB_LIBS)
+ ])
+])
+
else
dnl not building plugins with external dependencies,
@@ -851,6 +862,7 @@ AM_CONDITIONAL(USE_THEORADEC, false)
AM_CONDITIONAL(USE_XVID, false)
AM_CONDITIONAL(USE_WAVPACK, false)
AM_CONDITIONAL(USE_DVB, false)
+AM_CONDITIONAL(USE_ZLIB, false)
fi dnl of EXT plugins