summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2007-04-28 12:46:47 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-04-28 12:46:47 +0000
commit3f276737758839994faeca793d5eed582362a673 (patch)
tree6139843a0ac2ff185939ec013439329ef17e296e /configure.ac
parente78e486da81362557bacdf1c125dbb2a121019d2 (diff)
downloadgst-plugins-bad-3f276737758839994faeca793d5eed582362a673.tar.gz
gst-plugins-bad-3f276737758839994faeca793d5eed582362a673.tar.bz2
gst-plugins-bad-3f276737758839994faeca793d5eed582362a673.zip
configure.ac: Don't build equalizer unless we have core from CVS (it won't work with earlier versions due to GstChild...
Original commit message from CVS: * configure.ac: Don't build equalizer unless we have core from CVS (it won't work with earlier versions due to GstChildProxy brokeness). Also up requirements to last released core/base.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a05db5d2..782fe87e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,8 +44,9 @@ dnl AS_LIBTOOL_TAGS([CXX])
AM_PROG_LIBTOOL
dnl *** required versions of GStreamer stuff ***
-GST_REQ=0.10.11.1
-GSTPB_REQ=0.10.11.1
+dnl *** remove rtpmanager/equalizer stuff below when this is updated
+GST_REQ=0.10.12
+GSTPB_REQ=0.10.12
dnl *** autotools stuff ****
@@ -267,8 +268,16 @@ fi
dnl Disable rtpmanager if -base isn't the latest
dnl remove this when GSTPB_REQ is updated
-if ! pkg-config --atleast-version=0.10.12.1 gstreamer-plugins-base-0.10 ; then
+if ! $PKG_CONFIG --atleast-version=0.10.12.1 gstreamer-plugins-base-0.10 ; then
GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | $SED -e s/rtpmanager//`
+ AC_MSG_NOTICE([Not building rtpmanager, requires -base CVS (>= 0.10.12.1)])
+fi
+
+dnl Disable equalizer if we don't have core CVS (won't work otherwise)
+dnl remove this when GST_REQ is updated
+if ! $PKG_CONFIG --atleast-version=0.10.12.1 gstreamer-0.10 ; then
+ GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | $SED -e s/equalizer//`
+ AC_MSG_NOTICE([Not building equalizer, requires core CVS (>= 0.10.12.1)])
fi
AC_SUBST(GST_PLUGINS_SELECTED)