summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-01-30 19:19:33 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-01-30 19:19:33 +0000
commit65d96c70634b527ef8fc9f0b1669f42b87e788b7 (patch)
tree9975d8e3105265423750ed4ed46f85cafa1a5996 /configure.ac
parent8473ffb7541e8f5158b81883ab2b9a6c92c53e40 (diff)
downloadgst-plugins-bad-65d96c70634b527ef8fc9f0b1669f42b87e788b7.tar.gz
gst-plugins-bad-65d96c70634b527ef8fc9f0b1669f42b87e788b7.tar.bz2
gst-plugins-bad-65d96c70634b527ef8fc9f0b1669f42b87e788b7.zip
Fix build with exempi >= 1.99.5 and fix the include path for exempi.
Original commit message from CVS: * configure.ac: * ext/metadata/metadataxmp.c: (metadatamux_xmp_for_each_tag_in_list): Fix build with exempi >= 1.99.5 and fix the include path for exempi.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 4 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 20b96a6f..97ec66f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -519,15 +519,10 @@ AG_GST_CHECK_FEATURE(METADATA, [METADATA muxer and demuxer], metadata, [
PKG_CHECK_MODULES(IPTC, libiptcdata >= 1.0.2, HAVE_IPTC="yes", [
HAVE_IPTC="no"
])
- AC_CHECK_HEADER(exempi-2.0/exempi/xmp.h,
- [
- AC_CHECK_LIB(exempi, xmp_init,
- [
- HAVE_XMP="yes"
- XMP_CFLAGS="-I/usr/local/include/exempi-2.0/exempi/"
- XMP_LIBS="-lexempi"
- ], HAVE_XMP="no")
- ], HAVE_XMP="no")
+ PKG_CHECK_MODULES(XMP, exempi-2.0, HAVE_XMP="yes", [
+ HAVE_XMP="no"
+ ])
+ PKG_CHECK_MODULES(XMP_1_99_5, exempi-2.0 >= 1.99.5, XMP_CFLAGS="-DXMP_1_99_5 $XMP_CFLAGS", AC_MSG_RESULT(no))
if test x$HAVE_EXIF = xyes; then
METADATA_CFLAGS="-DHAVE_EXIF $EXIF_CFLAGS $METADATA_CFLAGS"
METADATA_LIBS="$EXIF_LIBS $METADATA_LIBS -lm"