summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2006-04-01 16:50:49 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2006-04-01 16:50:49 +0000
commit99d8cf0d15a412b1e3452a95cc2a5b94a47da2fc (patch)
treea268bd9ce2ed59a695abfa493c37308e6ef0b1a9 /configure.ac
parent3bf58dfa1c11135e4fd25cacb52b410f846ac8d1 (diff)
downloadgst-plugins-bad-99d8cf0d15a412b1e3452a95cc2a5b94a47da2fc.tar.gz
gst-plugins-bad-99d8cf0d15a412b1e3452a95cc2a5b94a47da2fc.tar.bz2
gst-plugins-bad-99d8cf0d15a412b1e3452a95cc2a5b94a47da2fc.zip
add taglib checks and docs
Original commit message from CVS: add taglib checks and docs
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index afcb58f3..ade77ab5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,11 @@ dnl *** checks for programs ***
dnl find a compiler
AC_PROG_CC
+dnl determine c++ compiler
+AC_PROG_CXX
+dnl determine if c++ is available on this system
+AC_CHECK_PROG(HAVE_CXX, $CXX, yes, no)
+
AC_PATH_PROG(VALGRIND_PATH, valgrind, no)
AM_CONDITIONAL(HAVE_VALGRIND, test ! "x$VALGRIND_PATH" = "xno")
@@ -157,6 +162,9 @@ AM_PATH_CHECK(0.9.2, HAVE_CHECK=yes, HAVE_CHECK=no)
AM_CONDITIONAL(HAVE_CHECK, test "x$HAVE_CHECK" = "xyes")
GST_CHECK_GST_PLUGINS_BASE($GST_MAJORMINOR, [$GSTPB_REQ], no)
+GSTPB_PLUGINS_DIR=`$PKG_CONFIG gstreamer-plugins-base-$GST_MAJORMINOR --variable pluginsdir`
+AC_SUBST(GSTPB_PLUGINS_DIR)
+AC_MSG_NOTICE(Using GStreamer Base Plugins in $GSTPB_PLUGINS_DIR)
dnl set license and copyright notice
GST_LICENSE="LGPL"
@@ -697,6 +705,7 @@ common/Makefile
common/m4/Makefile
m4/Makefile
tests/Makefile
+tests/check/Makefile
tests/icles/Makefile
)
AC_OUTPUT