summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2007-01-06 19:23:40 +0000
committerEdward Hervey <bilboed@bilboed.com>2007-01-06 19:23:40 +0000
commitc1429dc970ece9f8b177e4133db3f2cd61b23105 (patch)
tree8dd8ab3b3de3d9161f4ddc1f6c8558664e8e6881 /configure.ac
parent2b5fdf422e62d17fe018bf207aa363402dbbce24 (diff)
downloadgst-plugins-bad-c1429dc970ece9f8b177e4133db3f2cd61b23105.tar.gz
gst-plugins-bad-c1429dc970ece9f8b177e4133db3f2cd61b23105.tar.bz2
gst-plugins-bad-c1429dc970ece9f8b177e4133db3f2cd61b23105.zip
configure.ac: Properly detect the two architectures on which the real plugin can be built.
Original commit message from CVS: * configure.ac: Properly detect the two architectures on which the real plugin can be built. Fixes #393622
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e0c71400..a5b42b8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -227,8 +227,8 @@ if test "x$HAVE_CXX" != "xyes"; then
fi
dnl real plugin only works on i386 and x86_64 for the time being.
-if test "x$HAVE_CPU_I386" != "xyes" || test "xHAVE_CPU_X86_64" != "xyes"; then
- AC_MSG_WARN([Not building real plugin, only works on 32bit x86 platforms])
+if test "x$HAVE_CPU_I386" != "xyes" && test "x$HAVE_CPU_X86_64" != "xyes"; then
+ AC_MSG_WARN([Not building real plugin, only works on 32bit and 64bit x86 platforms])
GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | sed 's/real//g'`
fi