summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRené Stadler <mail@renestadler.de>2007-09-21 17:07:56 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2007-09-21 17:07:56 +0000
commit5739f5f3cec195ca6f9a5a1a1f9de7e4cd1c98f6 (patch)
tree88798381273ffd9162dfca9d271538c7ee2fbe7c /configure.ac
parent78960f293f797ec40eb5991468853cbb62907ab8 (diff)
downloadgst-plugins-bad-5739f5f3cec195ca6f9a5a1a1f9de7e4cd1c98f6.tar.gz
gst-plugins-bad-5739f5f3cec195ca6f9a5a1a1f9de7e4cd1c98f6.tar.bz2
gst-plugins-bad-5739f5f3cec195ca6f9a5a1a1f9de7e4cd1c98f6.zip
Add a GIO/GVFS plugin with source and sink elements. This will only be enabled when --enable-experimental is given to...
Original commit message from CVS: Patch by: René Stadler <mail at renestadler dot de> * configure.ac: * ext/Makefile.am: * ext/gio/Makefile.am: * ext/gio/gstgio.c: (gst_gio_error), (gst_gio_seek), (gst_gio_get_supported_protocols), (gst_gio_uri_handler_get_type_sink), (gst_gio_uri_handler_get_type_src), (gst_gio_uri_handler_get_protocols), (gst_gio_uri_handler_get_uri), (gst_gio_uri_handler_set_uri), (gst_gio_uri_handler_init), (gst_gio_uri_handler_do_init), (plugin_init): * ext/gio/gstgio.h: * ext/gio/gstgiosink.c: (gst_gio_sink_base_init), (gst_gio_sink_class_init), (gst_gio_sink_init), (gst_gio_sink_finalize), (gst_gio_sink_set_property), (gst_gio_sink_get_property), (gst_gio_sink_start), (gst_gio_sink_stop), (gst_gio_sink_unlock), (gst_gio_sink_unlock_stop), (gst_gio_sink_event), (gst_gio_sink_render), (gst_gio_sink_query): * ext/gio/gstgiosink.h: * ext/gio/gstgiosrc.c: (gst_gio_src_base_init), (gst_gio_src_class_init), (gst_gio_src_init), (gst_gio_src_finalize), (gst_gio_src_set_property), (gst_gio_src_get_property), (gst_gio_src_start), (gst_gio_src_stop), (gst_gio_src_get_size), (gst_gio_src_is_seekable), (gst_gio_src_unlock), (gst_gio_src_unlock_stop), (gst_gio_src_check_get_range), (gst_gio_src_create): * ext/gio/gstgiosrc.h: Add a GIO/GVFS plugin with source and sink elements. This will only be enabled when --enable-experimental is given to configure for now as the GIO API is not stable yet. Fixes #476916.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 67a5966b..9f28531f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,7 +122,7 @@ AG_GST_ARG_ENABLE_EXTERNAL
AG_GST_ARG_ENABLE_EXPERIMENTAL
-USE_TARKIN=$BUILD_EXPERIMENTAL
+USE_GIO=$BUILD_EXPERIMENTAL
dnl *** checks for platform ***
@@ -278,7 +278,6 @@ fi
AC_SUBST(GST_PLUGINS_SELECTED)
-
dnl *** sys plug-ins ***
dnl OpenGL
@@ -331,7 +330,6 @@ AG_GST_CHECK_FEATURE(X, [X libraries and plugins],
CPPFLAGS="$ac_cppflags_save"
])
-
dnl *** ext plug-ins ***
dnl keep this list sorted alphabetically !
@@ -531,6 +529,17 @@ AG_GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
AC_SUBST(FAAD_IS_NEAAC)
])
+dnl *** libgio ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_GIO, true)
+AG_GST_CHECK_FEATURE(GIO, [GIO standalone library], gio, [
+ PKG_CHECK_MODULES(GIO, gio-standalone >= 0.0.1, HAVE_GIO="yes", [
+ HAVE_GIO="no"
+ AC_MSG_RESULT(no)
+ ])
+ AC_SUBST(GIO_CFLAGS)
+ AC_SUBST(GIO_LIBS)
+])
+
dnl *** gsm ***
translit(dnm, m, l) AM_CONDITIONAL(USE_GSM, true)
AG_GST_CHECK_FEATURE(GSM, [GSM library], gsmenc gsmdec, [
@@ -899,6 +908,7 @@ AM_CONDITIONAL(USE_DTS, false)
AM_CONDITIONAL(USE_DIVX, false)
AM_CONDITIONAL(USE_FAAC, false)
AM_CONDITIONAL(USE_FAAD, false)
+AM_CONDITIONAL(USE_GIO, false)
AM_CONDITIONAL(USE_GSM, false)
AM_CONDITIONAL(USE_IVORBIS, false)
AM_CONDITIONAL(USE_JACK, false)
@@ -1029,6 +1039,7 @@ ext/divx/Makefile
ext/dts/Makefile
ext/faac/Makefile
ext/faad/Makefile
+ext/gio/Makefile
ext/gsm/Makefile
ext/ivorbis/Makefile
ext/jack/Makefile