summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2007-01-01 18:06:01 +0000
committerEdward Hervey <bilboed@bilboed.com>2007-01-01 18:06:01 +0000
commit6236d641f07a63c79057f0cb61f2f2e4085f1a03 (patch)
tree398a7eb1f2f9654b6fa3d3d54db089cb35174bfa /configure.ac
parentf905a15acc18b300c77d872079d37f6ed44e9567 (diff)
downloadgst-plugins-bad-6236d641f07a63c79057f0cb61f2f2e4085f1a03.tar.gz
gst-plugins-bad-6236d641f07a63c79057f0cb61f2f2e4085f1a03.tar.bz2
gst-plugins-bad-6236d641f07a63c79057f0cb61f2f2e4085f1a03.zip
configure.ac: Only build the plugin on 32bit x86 architectures.
Original commit message from CVS: * configure.ac: Only build the plugin on 32bit x86 architectures.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb52edb6..7a1bcd8e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -225,6 +225,12 @@ if test "x$HAVE_CXX" != "xyes"; then
AC_MSG_WARN([Not compiling plug-ins requiring C++ compiler])
GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | sed 's/modplug//g'`
fi
+
+dnl real plugin only works on 32bit x86 for the time being.
+if test "x$HAVE_CPU_I386" != "xyes" || test "xHAVE_CPU_X86_64" = "xyes"; then
+ AC_MSG_WARN([Not building real plugin, only works on 32bit x86 platforms])
+ GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | sed 's/real//g'`
+fi
AC_SUBST(GST_PLUGINS_SELECTED)