summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-07-18 08:34:06 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-07-18 08:34:06 +0000
commit26cb95316c8043e05365337660c1e07b067f298e (patch)
tree21f9652306edda7ca408ee1b389af80bca5a2d12 /configure.ac
parent32e80c449f3a29513111bceb7583a03fd22ca299 (diff)
downloadgst-plugins-bad-26cb95316c8043e05365337660c1e07b067f298e.tar.gz
gst-plugins-bad-26cb95316c8043e05365337660c1e07b067f298e.tar.bz2
gst-plugins-bad-26cb95316c8043e05365337660c1e07b067f298e.zip
Disable the tomsmocomp algorithm for this release as it's buggy and has no C implementation yet.
Original commit message from CVS: * configure.ac: * gst/deinterlace2/Makefile.am: * gst/deinterlace2/gstdeinterlace2.c: (gst_deinterlace2_methods_get_type), (gst_deinterlace2_set_method), (gst_deinterlace2_class_init), (gst_deinterlace2_init): * gst/deinterlace2/gstdeinterlace2.h: * gst/deinterlace2/tvtime/greedy.c: (gst_deinterlace_method_greedy_l_class_init): * gst/deinterlace2/tvtime/greedyh.c: (gst_deinterlace_method_greedy_h_class_init): * gst/deinterlace2/tvtime/vfir.c: (gst_deinterlace_method_vfir_class_init): Disable the tomsmocomp algorithm for this release as it's buggy and has no C implementation yet. Build the deinterlace2 plugin on all architectures but still mark it as experimental. Build the x86 inline assembly only if GCC inline assembly is supported and only on x86 or amd64. Fixes bug #543286.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 70ebaca5..7aea13f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -146,9 +146,6 @@ AS_GCC_INLINE_ASSEMBLY([HAVE_GCC_ASM=yes], [HAVE_GCC_ASM=no])
if test x$HAVE_GCC_ASM = xyes ; then
AC_DEFINE(HAVE_GCC_ASM, 1,
[Define if compiler supports gcc inline assembly])
-else
- AC_MSG_WARN([Not building deinterlace2 plugin, needs GCC inline assembly for now])
- AG_GST_DISABLE_PLUGIN(deinterlace2)
fi
AM_CONDITIONAL(HAVE_GCC_ASM, test "x$HAVE_GCC_ASM" = "xyes")
@@ -287,9 +284,6 @@ dnl real plugin only works on i386 and x86_64 for the time being.
if test "x$HAVE_CPU_I386" != "xyes" && test "x$HAVE_CPU_X86_64" != "xyes"; then
AC_MSG_WARN([Not building real plugin, only works on 32bit and 64bit x86 platforms])
AG_GST_DISABLE_PLUGIN(real)
-
- AC_MSG_WARN([Not building deinterlace2 plugin, only works on 32bit and 64bit x86 platforms for now])
- AG_GST_DISABLE_PLUGIN(deinterlace2)
fi
dnl disable experimental plug-ins