summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@noraisin.net>2009-04-23 17:33:25 +0100
committerJan Schmidt <thaytan@noraisin.net>2009-04-23 17:33:25 +0100
commit53ce1453d12119ab960d97fb612028787601779c (patch)
treed8c9eec149391a656f2df9023e8d0386094f3b96 /configure.ac
parent95520973d01118a464b9e2a550b04d7e722483a6 (diff)
downloadgst-plugins-bad-53ce1453d12119ab960d97fb612028787601779c.tar.gz
gst-plugins-bad-53ce1453d12119ab960d97fb612028787601779c.tar.bz2
gst-plugins-bad-53ce1453d12119ab960d97fb612028787601779c.zip
soundtouch: Fix compilation on newer libSoundTouch
Newer libsoundtouch requires that we include an extra header that wasn't previously required, so define HAVE_SOUNDTOUCH_1_4 for newer builds so that it gets included.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d6f6071f..5904e953 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1262,11 +1262,13 @@ AG_GST_CHECK_FEATURE(SOUNDTOUCH, [soundtouch plug-in], soundtouch, [
dnl We only need -lBPM on soundtouch < 1.4
dnl We check for libSoundTouch since Debian used it before upstream
dnl added a pkgconfig file.
+ HAVE_SOUNDTOUCH_1_4=yes
PKG_CHECK_MODULES(SOUNDTOUCH, soundtouch-1.4,
- HAVE_SOUNDTOUCH=yes,
+ [HAVE_SOUNDTOUCH=yes],
[PKG_CHECK_MODULES(SOUNDTOUCH, soundtouch-1.0,
- HAVE_SOUNDTOUCH=yes
- SOUNDTOUCH_LIBS=$"SOUNDTOUCH_LIBS -lBPM",
+ [HAVE_SOUNDTOUCH=yes
+ HAVE_SOUNDTOUCH_1_4=no
+ SOUNDTOUCH_LIBS=$"SOUNDTOUCH_LIBS -lBPM"],
[PKG_CHECK_MODULES(SOUNDTOUCH, libSoundTouch,
HAVE_SOUNDTOUCH=yes
SOUNDTOUCH_LIBS=$"SOUNDTOUCH_LIBS -lBPM",
@@ -1277,6 +1279,10 @@ AG_GST_CHECK_FEATURE(SOUNDTOUCH, [soundtouch plug-in], soundtouch, [
USE_SOUNDTOUCH=false
AC_MSG_NOTICE([Not building soundtouch plugin: no C++ compiler found])
fi
+ if test "x$HAVE_SOUNDTOUCH" = "xyes" -a "x$HAVE_SOUNDTOUCH_1_4" = "xyes"; then
+ AC_DEFINE([HAVE_SOUNDTOUCH_1_4], [1],
+ [Defined if the available libSoundTouch is >= 1.4])
+ fi
])
dnl *** spc ***