summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCarl-Anton Ingmarsson <ca.ingmarsson@gmail.com>2009-03-14 10:43:28 +0100
committerJan Schmidt <thaytan@noraisin.net>2009-06-20 15:21:18 +0100
commitb31ab745a506acb17a3f70119304d43b19a76988 (patch)
tree03dd08376cc2ad95b3c40a3bcb8ad86942093b5c /configure.ac
parentc70dbe94b5ff9a0993d852605d40c21020c59552 (diff)
downloadgst-plugins-bad-b31ab745a506acb17a3f70119304d43b19a76988.tar.gz
gst-plugins-bad-b31ab745a506acb17a3f70119304d43b19a76988.tar.bz2
gst-plugins-bad-b31ab745a506acb17a3f70119304d43b19a76988.zip
add new vdpau directory
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bd60b231..dde1cb81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1422,6 +1422,14 @@ AG_GST_CHECK_FEATURE(ACM, [Windows ACM library], acm, [
], [HAVE_ACM="no"])
])
+dnl *** vdpau ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_VDPAU, true)
+AG_GST_CHECK_FEATURE(VDPAU, [VDPAU], vdpau, [
+ AC_MSG_CHECKING([Checking for up to date vdpau installation])
+ AC_CHECK_HEADERS([vdpau/vdpau.h vdpau/vdpau_x11.h],
+ [HAVE_VDPAU="yes"], [HAVE_VDPAU="no"])
+])
+
else
dnl not building plugins with external dependencies,
@@ -1476,6 +1484,7 @@ AM_CONDITIONAL(USE_XVID, false)
AM_CONDITIONAL(USE_WILDMIDI, false)
AM_CONDITIONAL(USE_WININET, false)
AM_CONDITIONAL(USE_ACM, false)
+AM_CONDITIONAL(USE_VDPAU, false)
fi dnl of EXT plugins
@@ -1608,6 +1617,7 @@ sys/oss4/Makefile
sys/osxvideo/Makefile
sys/qtwrapper/Makefile
sys/vcd/Makefile
+sys/vdpau/Makefile
sys/wasapi/Makefile
sys/wininet/Makefile
sys/winks/Makefile