summaryrefslogtreecommitdiffstats
path: root/examples/app/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2008-06-06 16:50:51 +0000
committerWim Taymans <wim.taymans@gmail.com>2008-06-06 16:50:51 +0000
commit1ec82dec7203d670fa7bd7de48cafc52228a4e9d (patch)
tree33b322e5a5e0653a4c11d24a01a273df68199bfb /examples/app/Makefile.am
parent23692b06a08510828905576f15c86ab7925e516a (diff)
downloadgst-plugins-bad-1ec82dec7203d670fa7bd7de48cafc52228a4e9d.tar.gz
gst-plugins-bad-1ec82dec7203d670fa7bd7de48cafc52228a4e9d.tar.bz2
gst-plugins-bad-1ec82dec7203d670fa7bd7de48cafc52228a4e9d.zip
examples/app/: Added 3 more example application for using appsrc in random-access mode, pull-mode streaming and pull ...
Original commit message from CVS: * examples/app/Makefile.am: * examples/app/appsrc-ra.c: (feed_data), (seek_data), (found_source), (bus_message), (main): * examples/app/appsrc-seekable.c: (feed_data), (seek_data), (found_source), (bus_message), (main): * examples/app/appsrc-stream2.c: (feed_data), (found_source), (bus_message), (main): Added 3 more example application for using appsrc in random-access mode, pull-mode streaming and pull mode seekable. * gst-libs/gst/app/gstappsrc.c: (gst_app_src_class_init), (gst_app_src_start), (gst_app_src_do_get_size), (gst_app_src_create): * gst-libs/gst/app/gstappsrc.h: Make stream-type property writable. Unset flushing when starting so that we reuse appsrc. Inform basesrc about the configured size. Emit seek-data signal when we are going to a different offset in random-access mode.
Diffstat (limited to 'examples/app/Makefile.am')
-rw-r--r--examples/app/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/examples/app/Makefile.am b/examples/app/Makefile.am
index db1393dd..fc4b9419 100644
--- a/examples/app/Makefile.am
+++ b/examples/app/Makefile.am
@@ -1,5 +1,6 @@
-noinst_PROGRAMS = appsrc_ex appsrc-stream
+noinst_PROGRAMS = appsrc_ex appsrc-stream appsrc-stream2 appsrc-ra \
+ appsrc-seekable
appsrc_ex_SOURCES = appsrc_ex.c
appsrc_ex_CFLAGS = $(GST_CFLAGS) $(GCONF_CFLAGS)
@@ -10,3 +11,15 @@ appsrc_ex_LDFLAGS = \
appsrc_stream_SOURCES = appsrc-stream.c
appsrc_stream_CFLAGS = $(GST_CFLAGS) $(GCONF_CFLAGS)
appsrc_stream_LDFLAGS = $(GST_LIBS)
+
+appsrc_stream2_SOURCES = appsrc-stream2.c
+appsrc_stream2_CFLAGS = $(GST_CFLAGS) $(GCONF_CFLAGS)
+appsrc_stream2_LDFLAGS = $(GST_LIBS)
+
+appsrc_ra_SOURCES = appsrc-ra.c
+appsrc_ra_CFLAGS = $(GST_CFLAGS) $(GCONF_CFLAGS)
+appsrc_ra_LDFLAGS = $(GST_LIBS)
+
+appsrc_seekable_SOURCES = appsrc-seekable.c
+appsrc_seekable_CFLAGS = $(GST_CFLAGS) $(GCONF_CFLAGS)
+appsrc_seekable_LDFLAGS = $(GST_LIBS)