summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2002-03-18 04:41:35 +0000
committerAndy Wingo <wingo@pobox.com>2002-03-18 04:41:35 +0000
commit62c2ffe709c84bed65051e2b40f0322e79db8af8 (patch)
treefac5d59752e0d055a021dfc142d5cedea08b7fc1 /ext/Makefile.am
parent1e0d80ab837e0db1c78dd415b62d5ba2d876f763 (diff)
downloadgst-plugins-bad-62c2ffe709c84bed65051e2b40f0322e79db8af8.tar.gz
gst-plugins-bad-62c2ffe709c84bed65051e2b40f0322e79db8af8.tar.bz2
gst-plugins-bad-62c2ffe709c84bed65051e2b40f0322e79db8af8.zip
s/gst_element_install_std_props/gst_element_class_install_std_props/ -- it just makes more sense that way added jack ...
Original commit message from CVS: * s/gst_element_install_std_props/gst_element_class_install_std_props/ -- it just makes more sense that way * added jack element, doesn't quite work right yet but i didn't want to lose the work -- it does build, register, and attempt to run though * imposed some restrictions on the naming of request pads to better allow for reverse parsing * added '%s' to reverse parsing * added new bin flag to indicate that it is self-iterating, and some lame code in gst-launch to test it out * fixen on launch-gui * added pkg-config stuff for the editor's libs
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index e03242b7..39e6a986 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -100,6 +100,12 @@ else
HTTP_DIR=
endif
+if USE_JACK
+JACK_DIR=jack
+else
+JACK_DIR=
+endif
+
if USE_JPEG
JPEG_DIR=jpeg
else
@@ -203,7 +209,7 @@ SUBDIRS=$(A52DEC_DIR) $(AALIB_DIR) $(ALSA_DIR) \
$(AVIFILE_DIR) $(CDPARANOIA_DIR) $(DV_DIR) \
$(DVDREAD_DIR) $(ESD_DIR) $(FESTIVAL_DIR) \
$(FLAC_DIR) $(GNOMEVFS_DIR) $(GSM_DIR) \
- $(HERMES_DIR) $(HTTP_DIR) $(JPEG_DIR) \
+ $(HERMES_DIR) $(HTTP_DIR) $(JACK_DIR) $(JPEG_DIR) \
$(LADSPA_DIR) $(LAME_DIR) \
$(MAD_DIR) $(MIKMOD_DIR) $(MJPEGTOOLS_DIR) $(MPEG2DEC_DIR) \
$(OPENQUICKTIME_DIR) $(RAW1394_DIR) $(RTP_DIR) \
@@ -216,7 +222,7 @@ DIST_SUBDIRS=\
audiofile cdparanoia dv \
dvdread esd festival \
flac gnomevfs gsm \
- hermes http jpeg \
+ hermes http jack jpeg \
ladspa lame \
mad mikmod mjpegtools mpeg2dec \
openquicktime raw1394 rtp \