summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2004-01-12 03:21:40 +0000
committerDavid Schleef <ds@schleef.org>2004-01-12 03:21:40 +0000
commit538adea7fa1756c41e55c3b3e7f4bc9f6d206cfc (patch)
tree1cbfbad63371ae6900f4e36a273a5e75194a3067 /ext/Makefile.am
parent1adb86a5d6b2f1bb96568f6135e1fdb4d451e4cd (diff)
downloadgst-plugins-bad-538adea7fa1756c41e55c3b3e7f4bc9f6d206cfc.tar.gz
gst-plugins-bad-538adea7fa1756c41e55c3b3e7f4bc9f6d206cfc.tar.bz2
gst-plugins-bad-538adea7fa1756c41e55c3b3e7f4bc9f6d206cfc.zip
Fixes to make ext/libcaca compile.
Original commit message from CVS: * configure.ac: * ext/Makefile.am: Fixes to make ext/libcaca compile. * ext/divx/gstdivxdec.c: * ext/gdk_pixbuf/gstgdkpixbuf.c: (gst_gdk_pixbuf_sink_link), (gst_gdk_pixbuf_init), (gst_gdk_pixbuf_chain): Make gdkpixbufdec handle images that span multiple buffers. Now work with both filesrc ! gdkpixbufdec and qtdemux ! gdkpixbufdec. * ext/gdk_pixbuf/gstgdkpixbuf.h: * ext/libcaca/gstcacasink.h: Fixes needed due to recent video/video.h changes * ext/xvid/gstxvid.c: (gst_xvid_csp_to_caps): same * sys/v4l/gstv4lmjpegsrc.c: (gst_v4lmjpegsrc_get), (gst_v4lmjpegsrc_buffer_free): Use buffer free function instead of GstData free function. * sys/v4l/gstv4lsrc.c: (gst_v4lsrc_get), (gst_v4lsrc_buffer_free): same.
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index ec6955bb..a5e112cb 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -154,6 +154,12 @@ else
LCS_DIR=
endif
+if USE_LIBCACA
+LIBCACA_DIR=libcaca
+else
+LIBCACA_DIR=
+endif
+
if USE_LIBDV
LIBDV_DIR=dv
else
@@ -323,6 +329,7 @@ SUBDIRS=\
$(LADSPA_DIR) \
$(LAME_DIR) \
$(LCS_DIR) \
+ $(LIBCACA_DIR) \
$(LIBDV_DIR) \
$(LIBFAME_DIR) \
$(LIBPNG_DIR) \
@@ -376,6 +383,7 @@ DIST_SUBDIRS=\
ladspa \
lame \
lcs \
+ libcaca \
libfame \
libpng \
librfb \