summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorMichael Smith <msmith@xiph.org>2006-03-31 14:26:05 +0000
committerMichael Smith <msmith@xiph.org>2006-03-31 14:26:05 +0000
commit15d5008ffc61e32156316ebedb1a1fb5bf7a683f (patch)
treea65338fb184996cafa5f35097ba9eb7a48cf2ff7 /ext/Makefile.am
parentde433bfdcb5ba523f6e0c5ec0589f5bd890cee35 (diff)
downloadgst-plugins-bad-15d5008ffc61e32156316ebedb1a1fb5bf7a683f.tar.gz
gst-plugins-bad-15d5008ffc61e32156316ebedb1a1fb5bf7a683f.tar.bz2
gst-plugins-bad-15d5008ffc61e32156316ebedb1a1fb5bf7a683f.zip
configure.ac: Add autoconfery for theoradec.
Original commit message from CVS: * configure.ac: Add autoconfery for theoradec. * ext/Makefile.am: Add theora directory. * ext/theora/Makefile.am: * ext/theora/theoradec.c: (gst_theoradec_base_init), (gst_theoradec_class_init), (gst_theoradec_init), (gst_theoradec_reset), (inc_granulepos), (theora_get_query_types), (gst_theoradec_granule_clocktime), (theora_dec_src_convert), (theora_dec_sink_convert), (theora_dec_src_query), (theora_dec_sink_query), (theora_dec_src_event), (theora_dec_sink_event), (theora_handle_comment_packet), (theora_handle_type_packet), (theora_handle_header_packet), (theora_dec_push), (theora_handle_data_packet), (theora_dec_chain), (theora_dec_change_state), (plugin_init): * ext/theora/theoradec.h: Add theora plugin for theora-exp decoder. Very heavily based on the existing theora decoder plugin.
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 2ee8bf8d..4b6e741f 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -209,6 +209,13 @@ else
TAGLIB_DIR =
endif
+if USE_THEORADEC
+THEORA_DIR = theora
+else
+THEORA_DIR =
+endif
+
+
# if USE_TARKIN
# TARKIN_DIR=tarkin
# else
@@ -263,6 +270,7 @@ SUBDIRS=\
$(SWFDEC_DIR) \
$(TAGLIB_DIR) \
$(TARKIN_DIR) \
+ $(THEORA_DIR) \
$(WAVPACK_DIR) \
$(XINE_DIR) \
$(XVID_DIR)