summaryrefslogtreecommitdiffstats
path: root/ext/bz2/Makefile.am
diff options
context:
space:
mode:
authorLutz Müller <lutz@topfrose.de>2006-05-28 17:08:17 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-05-28 17:08:17 +0000
commit5956f87dd82fec00b197fc6c106c28218250a52b (patch)
tree3908875880b88fc9b701baea2cb485926ea7e3a2 /ext/bz2/Makefile.am
parente7cfdce6ce12271a7d961d79a060b0f9253a2b19 (diff)
downloadgst-plugins-bad-5956f87dd82fec00b197fc6c106c28218250a52b.tar.gz
gst-plugins-bad-5956f87dd82fec00b197fc6c106c28218250a52b.tar.bz2
gst-plugins-bad-5956f87dd82fec00b197fc6c106c28218250a52b.zip
ext/bz2/: Use gst_type_find_helper_* functions for typefinding; use correct caps with gst_pad_alloc_buffer(); add sta...
Original commit message from CVS: Patch by: Lutz Müller <lutz at topfrose de> * ext/bz2/Makefile.am: * ext/bz2/gstbz2dec.c: (gst_bz2dec_chain), (gst_bz2dec_init), (gst_bz2dec_change_state), (gst_bz2dec_class_init): Use gst_type_find_helper_* functions for typefinding; use correct caps with gst_pad_alloc_buffer(); add state change function and reset decoder in it; don't unref buffer if pad_push fails; use fixed caps on source pad. (#341524).
Diffstat (limited to 'ext/bz2/Makefile.am')
-rw-r--r--ext/bz2/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/ext/bz2/Makefile.am b/ext/bz2/Makefile.am
index 736351e3..1a984b46 100644
--- a/ext/bz2/Makefile.am
+++ b/ext/bz2/Makefile.am
@@ -3,8 +3,8 @@ plugin_LTLIBRARIES = libgstbz2.la
libgstbz2_la_SOURCES = \
gstbz2.c gstbz2dec.c gstbz2enc.c
-libgstbz2_la_CFLAGS = $(GST_CFLAGS)
-libgstbz2_la_LIBADD = $(BZ2_LIBS)
+libgstbz2_la_CFLAGS = $(GST_BASE_CFLAGS)
+libgstbz2_la_LIBADD = $(GST_BASE_LIBS) $(BZ2_LIBS)
libgstbz2_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = \