summaryrefslogtreecommitdiffstats
path: root/ext/dirac/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2008-03-06 03:16:13 +0000
committerDavid Schleef <ds@schleef.org>2008-03-06 03:16:13 +0000
commitb387715461ec1eab84eb2eb990e1a5562b9d8b42 (patch)
treee82c911268f803028e289187c857775b5e4fb3fd /ext/dirac/Makefile.am
parentacb81c58c547b0e6155fd61b7914f39deea428ad (diff)
downloadgst-plugins-bad-b387715461ec1eab84eb2eb990e1a5562b9d8b42.tar.gz
gst-plugins-bad-b387715461ec1eab84eb2eb990e1a5562b9d8b42.tar.bz2
gst-plugins-bad-b387715461ec1eab84eb2eb990e1a5562b9d8b42.zip
Rewrite Dirac encoder plugin based on Schroedinger gstreamer elements.
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/dirac/Makefile.am: * ext/dirac/gstdirac.cc: * ext/dirac/gstdiracenc.cc: Rewrite Dirac encoder plugin based on Schroedinger gstreamer elements.
Diffstat (limited to 'ext/dirac/Makefile.am')
-rw-r--r--ext/dirac/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/ext/dirac/Makefile.am b/ext/dirac/Makefile.am
index 1a73fb57..e2e326b0 100644
--- a/ext/dirac/Makefile.am
+++ b/ext/dirac/Makefile.am
@@ -2,11 +2,12 @@ plugin_LTLIBRARIES = libgstdirac.la
libgstdirac_la_SOURCES = \
gstdirac.cc \
- gstdiracdec.cc
+ gstdiracenc.cc
-libgstdirac_la_CXXFLAGS = $(GST_CFLAGS) $(DIRAC_CFLAGS)
-libgstdirac_la_LIBADD = $(DIRAC_LIBS) -lz $(LIBM)
+libgstdirac_la_CXXFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(DIRAC_CFLAGS)
+libgstdirac_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) $(DIRAC_LIBS) -lz $(LIBM)
libgstdirac_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = \
gstdiracdec.h
+