summaryrefslogtreecommitdiffstats
path: root/ext/divx/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-04-22 14:55:12 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-04-22 14:55:12 +0000
commit08889d7a8ffaac8e6195783d70e496ede7dea11d (patch)
treea56f1d6fa6e14b65074458b6eafa95c5564af02e /ext/divx/Makefile.am
parentcb4ce3dd598b1653461f5cc1b6276812699bb5f7 (diff)
downloadgst-plugins-bad-08889d7a8ffaac8e6195783d70e496ede7dea11d.tar.gz
gst-plugins-bad-08889d7a8ffaac8e6195783d70e496ede7dea11d.tar.bz2
gst-plugins-bad-08889d7a8ffaac8e6195783d70e496ede7dea11d.zip
Added corresponding divx/xvid decoders and fixed some first-hand encoder bugs
Original commit message from CVS: Added corresponding divx/xvid decoders and fixed some first-hand encoder bugs
Diffstat (limited to 'ext/divx/Makefile.am')
-rw-r--r--ext/divx/Makefile.am17
1 files changed, 11 insertions, 6 deletions
diff --git a/ext/divx/Makefile.am b/ext/divx/Makefile.am
index e6a6eaa5..301657c8 100644
--- a/ext/divx/Makefile.am
+++ b/ext/divx/Makefile.am
@@ -1,10 +1,15 @@
plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
-plugin_LTLIBRARIES = libgstdivx.la
+plugin_LTLIBRARIES = libgstdivxenc.la libgstdivxdec.la
-libgstdivx_la_SOURCES = gstdivxenc.c
-libgstdivx_la_CFLAGS = $(GST_CFLAGS) $(DIVX_CFLAGS)
-libgstdivx_la_LIBADD = $(DIVX_LIBS)
-libgstdivx_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstdivxenc_la_SOURCES = gstdivxenc.c
+libgstdivxenc_la_CFLAGS = $(GST_CFLAGS) $(DIVX_CFLAGS)
+libgstdivxenc_la_LIBADD = $(DIVXENC_LIBS)
+libgstdivxenc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gstdivxenc.h
+libgstdivxdec_la_SOURCES = gstdivxdec.c
+libgstdivxdec_la_CFLAGS = $(GST_CFLAGS) $(DIVX_CFLAGS)
+libgstdivxdec_la_LIBADD = $(DIVXDEC_LIBS)
+libgstdivxdec_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstdivxenc.h gstdivxdec.h