summaryrefslogtreecommitdiffstats
path: root/ext/gsm/Makefile.am
diff options
context:
space:
mode:
authorFlavio Oliveira <flavio.oliveira@indt.org.br>2005-09-02 20:21:17 +0000
committerFlavio Oliveira <flavio.oliveira@indt.org.br>2005-09-02 20:21:17 +0000
commit36634356e6bf464a8689657fe532265ea6870555 (patch)
tree6cbebcf971b256550bac4bbfea5e0b9884405047 /ext/gsm/Makefile.am
parent741afd1f75ed86d96e2f1f1a7d19eb34340ff676 (diff)
downloadgst-plugins-bad-36634356e6bf464a8689657fe532265ea6870555.tar.gz
gst-plugins-bad-36634356e6bf464a8689657fe532265ea6870555.tar.bz2
gst-plugins-bad-36634356e6bf464a8689657fe532265ea6870555.zip
Ported GSM Encoder to GStreamer 0.9
Original commit message from CVS: Ported GSM Encoder to GStreamer 0.9
Diffstat (limited to 'ext/gsm/Makefile.am')
-rw-r--r--ext/gsm/Makefile.am16
1 files changed, 5 insertions, 11 deletions
diff --git a/ext/gsm/Makefile.am b/ext/gsm/Makefile.am
index a3779668..6782a242 100644
--- a/ext/gsm/Makefile.am
+++ b/ext/gsm/Makefile.am
@@ -1,15 +1,9 @@
-
plugin_LTLIBRARIES = libgstgsm.la
-libgstgsm_la_SOURCES = gstgsm.c gstgsmdec.c gstgsmenc.c
-libgstgsm_la_CFLAGS = $(GST_CFLAGS)
-libgstgsm_la_LIBADD = $(GSM_LIBS)
+libgstgsm_la_SOURCES = gstgsm.c gstgsmenc.c
+libgstgsm_la_CFLAGS = $(GST_CFLAGS) $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+libgstgsm_la_LIBADD = $(GSM_LIBS) $(GST_PLUGINS_BASE_LIBS) \
+ -lgstaudio-@GST_MAJORMINOR@
libgstgsm_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gstgsmenc.h gstgsmdec.h
-
-#check_PROGRAMS = test
-
-#test_CFLAGS = $(GSM_CFLAGS)
-#test_LDADD = $(GSM_LIBS) $(top_srcdir)/gst/libgst.la
-#test_SOURCES = test.c
+noinst_HEADERS = gstgsmenc.h