summaryrefslogtreecommitdiffstats
path: root/ext/ladspa/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2005-08-25 09:30:24 +0000
committerAndy Wingo <wingo@pobox.com>2005-08-25 09:30:24 +0000
commit0f4381d9a2835d65de758306def86f41499ff362 (patch)
tree71ee391c5d9a5a95d81621315d81b9a75d8ae23f /ext/ladspa/Makefile.am
parent776f95cc79eb5947e96910c3f9a537649befac5c (diff)
downloadgst-plugins-bad-0f4381d9a2835d65de758306def86f41499ff362.tar.gz
gst-plugins-bad-0f4381d9a2835d65de758306def86f41499ff362.tar.bz2
gst-plugins-bad-0f4381d9a2835d65de758306def86f41499ff362.zip
ext/ladspa/gstladspa.*: Halfway-ported. Doesn't compile yet.
Original commit message from CVS: 2005-08-25 Andy Wingo <wingo@pobox.com> * ext/ladspa/gstladspa.h: * ext/ladspa/gstladspa.c: Halfway-ported. Doesn't compile yet. * ext/ladspa/gstsignalprocessor.h: * ext/ladspa/gstsignalprocessor.c: New files, the start of a base class for DSP elements. * configure.ac: Sort the external libs checks, add a ladspa check, output the ladspa makefile.
Diffstat (limited to 'ext/ladspa/Makefile.am')
-rw-r--r--ext/ladspa/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/ext/ladspa/Makefile.am b/ext/ladspa/Makefile.am
index c7c654fd..ce5302d5 100644
--- a/ext/ladspa/Makefile.am
+++ b/ext/ladspa/Makefile.am
@@ -1,9 +1,9 @@
plugin_LTLIBRARIES = libgstladspa.la
-libgstladspa_la_SOURCES = gstladspa.c search.c load.c
-libgstladspa_la_CFLAGS = $(GST_CFLAGS)
-libgstladspa_la_LIBADD = $(GST_LIBS)
+libgstladspa_la_SOURCES = gstsignalprocessor.c gstladspa.c search.c load.c
+libgstladspa_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+libgstladspa_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgstaudio-@GST_MAJORMINOR@
libgstladspa_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gstladspa.h utils.h
+noinst_HEADERS = gstsignalprocessor.h gstladspa.h utils.h