summaryrefslogtreecommitdiffstats
path: root/ext/mplex/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2002-10-24 22:37:51 +0000
committerWim Taymans <wim.taymans@gmail.com>2002-10-24 22:37:51 +0000
commit1496394c0f4be1a718fb189846c6350cbd9e43da (patch)
tree7f839063fd206ad3db102a7a20c336d0c8423295 /ext/mplex/Makefile.am
parent440801dd9e53284925575c2170b53bf947522414 (diff)
downloadgst-plugins-bad-1496394c0f4be1a718fb189846c6350cbd9e43da.tar.gz
gst-plugins-bad-1496394c0f4be1a718fb189846c6350cbd9e43da.tar.bz2
gst-plugins-bad-1496394c0f4be1a718fb189846c6350cbd9e43da.zip
First stab at porting mplex
Original commit message from CVS: First stab at porting mplex
Diffstat (limited to 'ext/mplex/Makefile.am')
-rw-r--r--ext/mplex/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/ext/mplex/Makefile.am b/ext/mplex/Makefile.am
new file mode 100644
index 00000000..c2d672cb
--- /dev/null
+++ b/ext/mplex/Makefile.am
@@ -0,0 +1,38 @@
+plugindir = $(libdir)/gst
+
+CC = g++
+
+EXTRA_DIST = \
+ README INSTRUCT TODO \
+ .cvsignore
+
+MAINTAINERCLEANFILES = Makefile.in
+
+gstmplex_SOURCES = \
+ bits.cc bits.hh \
+ buffer.cc buffer.hh \
+ videostrm.hh audiostrm.hh padstrm.hh \
+ videostrm_in.cc padstrm.cc \
+ lpcmstrm_in.cc mpastrm_in.cc ac3strm_in.cc \
+ videostrm_out.cc audiostrm_out.cc \
+ multplex.cc outputstream.hh \
+ systems.cc systems.hh \
+ vector.cc vector.hh mplexconsts.hh \
+ inputstrm.cc inputstrm.hh aunit.hh \
+ stillsstream.cc stillsstream.hh \
+ mjpeg_logging.cc mjpeg_logging.h \
+ yuv4mpeg.cc yuv4mpeg_ratio.cc yuv4mpeg.h \
+ mpegconsts.cc mpegconsts.h
+
+plugin_LTLIBRARIES = libgstmplex.la
+
+libgstmplex_la_SOURCES = gstmplex.cc \
+ $(gstmplex_SOURCES)
+
+libgstmplex_la_CXXFLAGS = $(GST_CFLAGS)
+libgstmplex_la_LIBADD = -lstdc++ $(LIBM_LIBS)
+libgstmplex_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstmplex.h
+
+