summaryrefslogtreecommitdiffstats
path: root/ext/smoothwave/Makefile.am
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2004-11-12 17:37:49 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2004-11-12 17:37:49 +0000
commit352cb6fef9ba3d73a3376244498e01498be68d43 (patch)
tree797516d8b1f8e2caf871b6ebbadbb9bf3bb98373 /ext/smoothwave/Makefile.am
parentbf61de8fe09a4f2c0d1109bc509ea8e4759fe222 (diff)
downloadgst-plugins-bad-352cb6fef9ba3d73a3376244498e01498be68d43.tar.gz
gst-plugins-bad-352cb6fef9ba3d73a3376244498e01498be68d43.tar.bz2
gst-plugins-bad-352cb6fef9ba3d73a3376244498e01498be68d43.zip
Update libvisual to 0.1.7. Link in the debug handling to gstreamer
Original commit message from CVS: * configure.ac: * ext/libvisual/visual.c: (gst_visual_get_type), (libvisual_log_handler), (gst_visual_getcaps), (gst_visual_srclink), (gst_visual_change_state), (make_valid_name), (plugin_init): Update libvisual to 0.1.7. Link in the debug handling to gstreamer * ext/smoothwave/Makefile.am: * ext/smoothwave/demo-osssrc.c: (main): * ext/smoothwave/gstsmoothwave.c: (gst_smoothwave_class_init), (gst_smoothwave_init), (gst_smoothwave_dispose), (gst_sw_sinklink), (gst_sw_srclink), (gst_smoothwave_chain), (gst_sw_change_state), (plugin_init): * ext/smoothwave/gstsmoothwave.h: Make gstsmoothwave a working element in the 20th century. * gst/chart/gstchart.c: (gst_chart_init), (gst_chart_srcconnect): Fix incorrect link function
Diffstat (limited to 'ext/smoothwave/Makefile.am')
-rw-r--r--ext/smoothwave/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/ext/smoothwave/Makefile.am b/ext/smoothwave/Makefile.am
index 6dd55d9c..d7312a4f 100644
--- a/ext/smoothwave/Makefile.am
+++ b/ext/smoothwave/Makefile.am
@@ -2,18 +2,17 @@
plugin_LTLIBRARIES = libgstsmoothwave.la
libgstsmoothwave_la_SOURCES = gstsmoothwave.c
-libgstsmoothwave_la_CFLAGS = $(GST_CFLAGS) $(GTK_CFLAGS)
-libgstsmoothwave_la_LIBADD = $(GTK_LIBS)
+libgstsmoothwave_la_CFLAGS = $(GST_CFLAGS)
+libgstsmoothwave_la_LIBADD =
libgstsmoothwave_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstsmoothwave.h
if HAVE_GTK
noinst_PROGRAMS = demo-osssrc
-endif
-
demo_osssrc_SOURCES = demo-osssrc.c
demo_osssrc_CFLAGS = $(GST_CFLAGS) $(GTK_CFLAGS)
demo_osssrc_LDFLAGS = $(GST_LIBS) $(GTK_LIBS)
+endif
EXTRA_DIST = README