summaryrefslogtreecommitdiffstats
path: root/ext/spc/Makefile.am
diff options
context:
space:
mode:
authorBrian Koropoff <brianhk@cs.washington.edu>2008-05-20 09:04:48 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-05-20 09:04:48 +0000
commit61dbbd46cc02f240bd7474c8e867ff67cfa8b4d4 (patch)
tree4d08d21bd29b53622ea52112d773dfc4706a3933 /ext/spc/Makefile.am
parentb641c49a4c4d1cb05b95538d83144a3ad5c1326f (diff)
downloadgst-plugins-bad-61dbbd46cc02f240bd7474c8e867ff67cfa8b4d4.tar.gz
gst-plugins-bad-61dbbd46cc02f240bd7474c8e867ff67cfa8b4d4.tar.bz2
gst-plugins-bad-61dbbd46cc02f240bd7474c8e867ff67cfa8b4d4.zip
ext/spc/: Add support for some essential features like seeking, reading song duration and extended tags. Fixes bug #4...
Original commit message from CVS: Patch by: Brian Koropoff <brianhk at cs dot washington dot edu> * ext/spc/Makefile.am: * ext/spc/gstspc.c: (gst_spc_dec_class_init), (gst_spc_dec_src_query_type), (gst_spc_dec_init), (gst_spc_dec_dispose), (gst_spc_dec_sink_event), (gst_spc_duration), (gst_spc_fadeout), (gst_spc_dec_src_event), (gst_spc_dec_src_query), (spc_play), (spc_setup): * ext/spc/gstspc.h: * ext/spc/tag.c: (spc_tag_is_extended), (spc_tag_is_text_format), (spc_tag_is_present), (spc_tag_unpack_date), (spc_tag_clear), (spc_tag_get_info), (spc_tag_free): * ext/spc/tag.h: Add support for some essential features like seeking, reading song duration and extended tags. Fixes bug #454151.
Diffstat (limited to 'ext/spc/Makefile.am')
-rw-r--r--ext/spc/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/ext/spc/Makefile.am b/ext/spc/Makefile.am
index 18a878b2..656421bc 100644
--- a/ext/spc/Makefile.am
+++ b/ext/spc/Makefile.am
@@ -1,6 +1,6 @@
plugin_LTLIBRARIES = libgstspc.la
-libgstspc_la_SOURCES = gstspc.c
+libgstspc_la_SOURCES = gstspc.c tag.c
libgstspc_la_CFLAGS = $(GST_CFLAGS) $(SPC_CFLAGS)
libgstspc_la_LIBADD = $(GST_LIBS) $(SPC_LIBS)