summaryrefslogtreecommitdiffstats
path: root/ext/x264/Makefile.am
diff options
context:
space:
mode:
authorMark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>2008-08-08 10:13:36 +0000
committerMark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>2008-08-08 10:13:36 +0000
commitf6d9b82fb839ed9fb88ad0ae74dff3a21bf54b6d (patch)
treee5a3c3124f6bbe9a93dc5dcbd7bc8de19ed16fcd /ext/x264/Makefile.am
parent106b2a7a379d6ce02610ab2b8f1f54e487cf54a6 (diff)
downloadgst-plugins-bad-f6d9b82fb839ed9fb88ad0ae74dff3a21bf54b6d.tar.gz
gst-plugins-bad-f6d9b82fb839ed9fb88ad0ae74dff3a21bf54b6d.tar.bz2
gst-plugins-bad-f6d9b82fb839ed9fb88ad0ae74dff3a21bf54b6d.zip
ext/x264/: Use video format library and GST_WRITE_*_BE macros where applicable.
Original commit message from CVS: * ext/x264/Makefile.am: * ext/x264/gstx264enc.c: (gst_x264_enc_header_buf), (gst_x264_enc_sink_set_caps), (gst_x264_enc_base_init), (gst_x264_enc_class_init), (gst_x264_enc_log_callback), (gst_x264_enc_init), (gst_x264_enc_init_encoder), (gst_x264_enc_finalize), (gst_x264_enc_chain), (gst_x264_enc_encode_frame), (plugin_init): * ext/x264/gstx264enc.h: Use video format library and GST_WRITE_*_BE macros where applicable. Use finalize in stead of dispose. Set up debug category and log callback.
Diffstat (limited to 'ext/x264/Makefile.am')
-rw-r--r--ext/x264/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/ext/x264/Makefile.am b/ext/x264/Makefile.am
index 35906d93..4369f46b 100644
--- a/ext/x264/Makefile.am
+++ b/ext/x264/Makefile.am
@@ -1,8 +1,9 @@
plugin_LTLIBRARIES = libgstx264.la
libgstx264_la_SOURCES = gstx264enc.c
-libgstx264_la_CFLAGS = $(X264_CFLAGS) $(GST_CFLAGS)
-libgstx264_la_LIBADD = $(X264_LIBS) $(GST_LIBS)
+libgstx264_la_CFLAGS = $(X264_CFLAGS) $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+libgstx264_la_LIBADD = $(X264_LIBS) $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS) \
+ -lgstvideo-$(GST_MAJORMINOR)
libgstx264_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstx264enc.h