summaryrefslogtreecommitdiffstats
path: root/gst-libs/ext/mplex/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2003-07-26 03:01:58 +0000
committerDavid Schleef <ds@schleef.org>2003-07-26 03:01:58 +0000
commit2f0cc8ec30e8c26fed7b2c9ac2614c9a7655fb65 (patch)
tree25c3fbda1c8f8f5a33cad05c78b40887be7d2fba /gst-libs/ext/mplex/Makefile.am
parent4df5590ec318054389219b84153cce0ce363613b (diff)
downloadgst-plugins-bad-2f0cc8ec30e8c26fed7b2c9ac2614c9a7655fb65.tar.gz
gst-plugins-bad-2f0cc8ec30e8c26fed7b2c9ac2614c9a7655fb65.tar.bz2
gst-plugins-bad-2f0cc8ec30e8c26fed7b2c9ac2614c9a7655fb65.zip
Moved from gst-plugins/ext/mplex/. See that directory for older changelogs.
Original commit message from CVS: Moved from gst-plugins/ext/mplex/. See that directory for older changelogs.
Diffstat (limited to 'gst-libs/ext/mplex/Makefile.am')
-rw-r--r--gst-libs/ext/mplex/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/gst-libs/ext/mplex/Makefile.am b/gst-libs/ext/mplex/Makefile.am
new file mode 100644
index 00000000..71d8aeb7
--- /dev/null
+++ b/gst-libs/ext/mplex/Makefile.am
@@ -0,0 +1,26 @@
+
+EXTRA_DIST = README INSTRUCT TODO
+
+noinst_LTLIBRARIES = libmplex.la
+
+libmplex_la_SOURCES = \
+ bits.cc bits.hh \
+ buffer.cc buffer.hh \
+ videostrm.hh audiostrm.hh padstrm.hh \
+ videostrm_in.cc padstrm.cc \
+ lpcmstrm_in.cc mpastrm_in.cc ac3strm_in.cc \
+ videostrm_out.cc audiostrm_out.cc \
+ multplex.cc outputstream.hh \
+ systems.cc systems.hh \
+ vector.cc vector.hh mplexconsts.hh \
+ inputstrm.cc inputstrm.hh aunit.hh \
+ stillsstream.cc stillsstream.hh \
+ mjpeg_logging.cc mjpeg_logging.h \
+ yuv4mpeg.cc yuv4mpeg_ratio.cc yuv4mpeg.h \
+ mpegconsts.cc mpegconsts.h
+
+libmplex_la_CXXFLAGS = $(GST_CFLAGS)
+libmplex_la_LIBADD = -lstdc++ $(LIBM_LIBS)
+libmplex_la_LDFLAGS =
+
+