summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2003-10-30 02:36:42 +0000
committerDavid Schleef <ds@schleef.org>2003-10-30 02:36:42 +0000
commit3e49bcfc01fcb2a46935f528fa2dccfeaf29803a (patch)
treec9446d636fbf953b291f254e932e948d2d2f783c /gst-libs/gst/Makefile.am
parentc186da6a66001e3de61d53212c708fd2e6cab5d2 (diff)
downloadgst-plugins-bad-3e49bcfc01fcb2a46935f528fa2dccfeaf29803a.tar.gz
gst-plugins-bad-3e49bcfc01fcb2a46935f528fa2dccfeaf29803a.tar.bz2
gst-plugins-bad-3e49bcfc01fcb2a46935f528fa2dccfeaf29803a.zip
Fix makefiles for GstPropertyProbe. Combine all interfaces into a single libgst-interface.
Original commit message from CVS: Fix makefiles for GstPropertyProbe. Combine all interfaces into a single libgst-interface.
Diffstat (limited to 'gst-libs/gst/Makefile.am')
-rw-r--r--gst-libs/gst/Makefile.am25
1 files changed, 21 insertions, 4 deletions
diff --git a/gst-libs/gst/Makefile.am b/gst-libs/gst/Makefile.am
index 06f12a07..699e5896 100644
--- a/gst-libs/gst/Makefile.am
+++ b/gst-libs/gst/Makefile.am
@@ -12,12 +12,29 @@ endif
SUBDIRS = audio colorbalance floatcast \
$(GCONF_DIR) idct media-info \
- mixer navigation play \
- resample riff tuner video \
+ mixer navigation play propertyprobe \
+ resample tuner video \
xoverlay $(X_DIR)
DIST_SUBDIRS = audio colorbalance floatcast \
gconf idct media-info \
- mixer navigation play \
- resample riff tuner video \
+ mixer navigation play propertyprobe \
+ resample tuner video \
xoverlay xwindowlistener
+
+
+lib_LTLIBRARIES = libgst-interfaces-@GST_MAJORMINOR@.la
+
+libgst_interfaces_@GST_MAJORMINOR@_la_SOURCES =
+
+libgst_interfaces_@GST_MAJORMINOR@_la_LIBADD = \
+ colorbalance/libgstcolorbalance.la \
+ mixer/libgstmixer.la \
+ navigation/libgstnavigation.la \
+ propertyprobe/libgstpropertyprobe.la \
+ tuner/libgsttuner.la \
+ xoverlay/libgstxoverlay.la \
+ $(GST_LIBS)
+
+libgst_interfaces_@GST_MAJORMINOR@_la_LDFLAGS = @GST_PLUGINS_LT_LDFLAGS@ -version-info @GST_PLUGINS_LIBVERSION@
+