summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/app/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2008-05-07 10:38:23 +0000
committerWim Taymans <wim.taymans@gmail.com>2008-05-07 10:38:23 +0000
commitb2aee5ef7612fa9adf9f69a5b984172886f7f0b3 (patch)
treead797cb4b7cb36e33e36b3549e2ae7f297700b1e /gst-libs/gst/app/Makefile.am
parent42d7c3409f0f58e204c57c026fd6333969d50103 (diff)
downloadgst-plugins-bad-b2aee5ef7612fa9adf9f69a5b984172886f7f0b3.tar.gz
gst-plugins-bad-b2aee5ef7612fa9adf9f69a5b984172886f7f0b3.tar.bz2
gst-plugins-bad-b2aee5ef7612fa9adf9f69a5b984172886f7f0b3.zip
gst-libs/gst/app/: Add marshal.list, make it compile and add to cvsignore.
Original commit message from CVS: * gst-libs/gst/app/.cvsignore: * gst-libs/gst/app/Makefile.am: * gst-libs/gst/app/gstapp-marshal.list: Add marshal.list, make it compile and add to cvsignore. * gst-libs/gst/app/gstappsink.c: (gst_app_sink_dispose), (gst_app_sink_stop): Small cleanups. * gst-libs/gst/app/gstappsrc.c: (gst_app_src_class_init), (gst_app_src_init), (gst_app_src_set_property), (gst_app_src_get_property), (gst_app_src_unlock), (gst_app_src_unlock_stop), (gst_app_src_start), (gst_app_src_stop), (gst_app_src_create), (gst_app_src_set_caps), (gst_app_src_get_caps), (gst_app_src_set_size), (gst_app_src_get_size), (gst_app_src_set_seekable), (gst_app_src_get_seekable), (gst_app_src_set_max_buffers), (gst_app_src_get_max_buffers), (gst_app_src_push_buffer), (gst_app_src_end_of_stream): * gst-libs/gst/app/gstappsrc.h: Beat appsrc in shape, add signals and actions. Add some docs. Add properties for caps, size, seekability and max-buffers. Fix unlock/stop code.
Diffstat (limited to 'gst-libs/gst/app/Makefile.am')
-rw-r--r--gst-libs/gst/app/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/gst-libs/gst/app/Makefile.am b/gst-libs/gst/app/Makefile.am
index 83925c91..d39572aa 100644
--- a/gst-libs/gst/app/Makefile.am
+++ b/gst-libs/gst/app/Makefile.am
@@ -1,6 +1,19 @@
lib_LTLIBRARIES = libgstapp-@GST_MAJORMINOR@.la
-libgstapp_@GST_MAJORMINOR@_la_SOURCES = gstappsrc.c gstappbuffer.c gstappsink.c
+glib_enum_define = GST_APP
+glib_enum_prefix = gst_app
+
+include $(top_srcdir)/common/glib-gen.mak
+
+built_sources = gstapp-marshal.c
+built_headers = gstapp-marshal.h
+
+BUILT_SOURCES = $(built_sources) $(built_headers)
+
+nodist_libgstapp_@GST_MAJORMINOR@_la_SOURCES = \
+ $(built_sources)
+
+libgstapp_@GST_MAJORMINOR@_la_SOURCES = gstappsrc.c gstappbuffer.c gstappsink.c
libgstapp_@GST_MAJORMINOR@_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
$(GST_PLUGINS_BASE_CFLAGS)
libgstapp_@GST_MAJORMINOR@_la_LIBADD = $(GST_BASE_LIBS)
@@ -12,3 +25,7 @@ libgstapp_@GST_MAJORMINOR@include_HEADERS = \
gstappbuffer.h \
gstappsink.h
+CLEANFILES = $(BUILT_SOURCES)
+
+EXTRA_DIST = gstapp-marshal.list
+